Go Back   DIY Chatroom Home Improvement Forum > Do It Yourself > Automotive Repairs

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-07-2012, 08:26 AM   #1
Still Learning
 
Join Date: Oct 2009
Location: Los Angeles
Posts: 338
Share |
Default

transmission and engine help!


Ok this is a two part question, 1) how do I determine what kind of transmittion I have, 2) how do I know if my oxygen sensor is bad?

I have a 1989 Chevy C3500 with a 350 automatic 2 wheel drive.

I have been having an issue with my truck since the last time I drove it to Vegas and back. It seems sluggish and bogged down. It struggles to keep the idle for a few seconds after starting the engine. Also the gas pedal stick when you push on it sometimes you gotta push hard to break the sticky. The sluggish problem is intermittent. In the past one of the fuel injectors wasn't firing so I sprayed liquid wrench into the intake manifold and it fixed the problem. Well I did it again yesterday and it ran good last night but its back to running like Crap and both fuel injectors are spitting out gas. I changed the air filter, put Lucas in the gas tank, and I found one of the spark plug wires was melted onto the exhaust manifold. Keep in mind the truck has been running very rich since I had it, but I replaced the spark plugs and wires and distributed cap with rotor 6 months ago. Should I pull one off to see if its bad or no? I changed the thermostat and the engine temp sensor. The only two Ideas I can think of is either the oxygen sensor is bad, or the computer still thinks there is a 454 in there (which was the OEM engine for this truck).

This problem caused the second problem. I'm moving to Idaho and I'm pulling a 6x12 trailer loaded with my bed loaded. And since there is not enough power coming out of the engine I was only able to go 25mph up that steep Ass hill just before the Nevada border. On the way down the hill the tranny was revving really high and it started smelling real bad. Now it has problems shifting and doesn't go into 6th gear or 5th gear, going 55mph its revving real high. I'm waiting in front of aamco waiting for them to open so this is on my mind.

I really appreciate any advice as I'm broke and relocating and I work on houses not cars. It's hard to get an honest answer about my truck...

thehvacguy is offline   Reply With Quote
Old 11-07-2012, 08:39 AM   #2
DIY staff
 
Join Date: Sep 2009
Location: Kane county,Illinois
Posts: 21,249
Default

transmission and engine help!


I'm not a car jockey---but there are a few here-----I feel for you---let's see who chimes in----where are you heading?

__________________
New members: Adding your location to your profile helps in many ways.--M--
oh'mike is offline   Reply With Quote
Old 11-07-2012, 08:47 AM   #3
Still Learning
 
Join Date: Oct 2009
Location: Los Angeles
Posts: 338
Default

transmission and engine help!


Idaho falls. I'm about 1/3 of the way there and there is 2 more passes I have to go over
thehvacguy is offline   Reply With Quote
Old 11-07-2012, 10:00 AM   #4
JOATMON
 
ddawg16's Avatar
 
Join Date: Aug 2011
Location: S. California
Posts: 6,817
Default

transmission and engine help!


You have a 5.7L TBI setup....your transmission is most likely a 700R....(in 93 it became electronic and was called the 4L60E or 4L80E.

You have OBDI....so I would go to your local auto parts store and ask them to put the scanner on it...specifically, look at the engine temp. If the reading from your temp sending unit is low, it causes the engine to run rich.

Next....check compression.....If compression is good, basically rules out issues with the timing chain.

Transmission? Reving high? You may have lost the vac modulator....that tells it when to upshift based on manifold vacuum

You could have a real bad vacuum leak....
__________________
"The dream is free but the hustle is sold separately."

My 2-Story Addition Build in Progress Link ... My Garage Build Link and My Jeep Build Link
ddawg16 is online now   Reply With Quote
Old 11-07-2012, 10:10 AM   #5
Still Learning
 
Join Date: Oct 2009
Location: Los Angeles
Posts: 338
Default

transmission and engine help!


I am at aamco and they are sayin because I have obd1 the light has to be on for the scanner deal to work. It only comes on randomly when I'm driving then goes off randomly.

If there is a vaccume leak what kind of damage would I do to my vehicle by pulling a loaded trailer about 500miles more?
thehvacguy is offline   Reply With Quote
Old 11-07-2012, 10:12 AM   #6
Still Learning
 
Join Date: Oct 2009
Location: Los Angeles
Posts: 338
Default

transmission and engine help!


Also I have around 120 PSI on all cylinders. Is that an acceptable level?
thehvacguy is offline   Reply With Quote
Old 11-07-2012, 10:13 AM   #7
Member
 
Join Date: Sep 2008
Location: Oregon
Posts: 1,497
Default

transmission and engine help!


Take your VIN number (should be on vehicle registration) to a GM dealer parts department. Then ask for a printout of your option codes. This will say what factory options you have (including transmission).

This is also in factory service manual information books for your SPECIFIC vehicle/year, set of 4 books typically, and can be ordered from the dealer.

Don't use VIN decoders on any old internet web page because those may be for different years and might not be correct for your specific year/model. (Lots of misinformation on the internet, get it straight from the horse [dealer/factory].)

Oxygen sensors should be replaced every 30,000 miles. This will give you better gas mileage, so it pays for itself.
Billy_Bob is offline   Reply With Quote
Old 11-07-2012, 11:14 AM   #8
JOATMON
 
ddawg16's Avatar
 
Join Date: Aug 2011
Location: S. California
Posts: 6,817
Default

transmission and engine help!


Sounds like AAMCO only has a code reader and not a real scanner.

A vacuum gauge will tell you if you have a vacuum leak.....you should be getting around 22" at idle....

Inspect all your vacuum lines.

120 PSI on the compression? If the engine is warm....that is a 'little' low....130 would be a bit better. 110 or less and you have issues. If all the cylinders are within 10% of each other....then I think your ok in that area.

How many miles on the engine?
__________________
"The dream is free but the hustle is sold separately."

My 2-Story Addition Build in Progress Link ... My Garage Build Link and My Jeep Build Link
ddawg16 is online now   Reply With Quote
Old 11-07-2012, 02:23 PM   #9
Newbie
 
Join Date: Oct 2012
Location: Mo
Posts: 29
Default

transmission and engine help!


3500 could have a 400th trans.
Mo Guy is offline   Reply With Quote
Old 11-07-2012, 06:00 PM   #10
Member
 
ukrkoz's Avatar
 
Join Date: Dec 2010
Posts: 559
Default

transmission and engine help!


for the year, 120m is pretty good. it's 23 year old engine, folks...

1. sticky gas pedal. disconnect air intake duct from your throttle body, equip yourself with rag, toothbrush, and brake cleaner (cheap and works fine); manually pop pintle valve open and liberally spray everything inside with cleaner; wipe it all off clean. Reason you need toothbrush is because you need to clean upper part of throttle intake, and it is very hard to do by hand. Toothbrush will do the job
2. sticky pintle valve leads me to believe that your EGR valve is at least needing cleaning. EGR WILL give you your symptoms. Normally, it can be removed and cleaned - yes, with same brake cleaner; be prepared to not bust metal gasket, as they are very brittle, and burn tight to exhaust. You bust it, you will not find another one, as they are made out of metal. I'd say, for the age - simply replace it.
3. BUY YOURSELF REPAIR MANUAL.
4. You know, miser always pays twice. Fork for $70 or so, take truck to a pro shop (no need for dealer) and have them run full scan on it. THEN ask them to point at parts in question, take pictures, and DIY them. Regular parts stores will not run scan on OBDI engines. Not set.
ukrkoz is offline   Reply With Quote
Old 11-08-2012, 07:32 AM   #11
DIY staff
 
Join Date: Sep 2009
Location: Kane county,Illinois
Posts: 21,249
Default

transmission and engine help!


How are you doing?????
__________________
New members: Adding your location to your profile helps in many ways.--M--
oh'mike is offline   Reply With Quote
Old 11-17-2012, 12:03 AM   #12
Still Learning
 
Join Date: Oct 2009
Location: Los Angeles
Posts: 338
Default

transmission and engine help!


Well folks thanks for all the great advise. We made it to Idaho and the truck is doin ok for around town driving. Just got hired at an HVAC company and busting out major overtime plus remodeling on my dads apartment complex. I haven't had time to work on my truck but Sunday I'm gonna check the compression again and do a vacuum test. The regards at aamco were tryin to sell me a fuel pump. It's terrible I can't seem to find a mechanic that really knows what he is doing. I'm a mechanical guy and when someone is bs ING me its clear as day to me. I got a repair manual from autozone but I still got everything in boxes. I wanna clean that throttle body like one of you were saying but I need to take caution not to screw things up. For some reason the gas pedal hasn't been sticking since I been up here but its been idling real weird and I got a lot of white smoke comin out the exhaust. I don't know if its the altitude or the cold or what but I don't think I blew a head Gasket cause I been checking my oil and the temp on the dash looks normal. I just put a Craigslist ad out for an obd1 machine cause they are kinda expensive for me right now. This will be a long term project. Big bertha has over 300k miles on her but the engine was changed to a 350 out of a caprice and I can't for the life of me figure out the year of it. I got the numbers off the engine block and called everyone under the sun and nobody can cross them so its sort of a guessing game as far as that's concerned, but I do know its a late 80's model for sure. I'm real lucky we made it here alive. The trailer was way overloaded, the upper control ARM bushings on the driver side are gone, the runner is all coming out, and before we left I went to a reputable shop and had then check the front end and they wouldn't even talk about the bushings. They sold me a pitman ARM and it wasn't even that. The gearbox is messed up. The pitman ARM won't go all the way up to the gearbox there is like an inch gap there and the grooves on the gearbox are worn out from shaking around. I got my work cut out for me but for now she is getting me around town and I take it easy as I keep fixin her up. I will update Yall next week if I get some time to work on her.
thehvacguy is offline   Reply With Quote
Old 11-17-2012, 06:53 AM   #13
Member
 
raylo32's Avatar
 
Join Date: Nov 2006
Location: Maryland (DC 'burbs)
Posts: 1,044
Default

transmission and engine help!


I can't help with your problems since it sounds to me like there's several things going on there. But a little advice from someone who spent a winter in Idaho falls.... Get an engine heater or soon you won't have to worry about the truck running bad because it will be so cold it won't even start!
__________________
Live long and prosper.
raylo32 is offline   Reply With Quote
Old 11-17-2012, 08:27 AM   #14
Still Learning
 
Join Date: Oct 2009
Location: Los Angeles
Posts: 338
Default

transmission and engine help!


What's an engine heater? I never heard of that...
thehvacguy is offline   Reply With Quote
Old 11-17-2012, 08:48 AM   #15
bbo
Member
 
Join Date: Feb 2010
Location: Packerland !!
Posts: 1,016
Default

transmission and engine help!


Quote:
Originally Posted by thehvacguy View Post
What's an engine heater? I never heard of that...

simple magnetic heater would work for you.

stick to oil pan or engine block, plug in when you need to warm it up ( a timer set for a few hours before starting should work fine. )


there are many kinds you can get, but the magnetic one is simplest to put on, followed by the lower rad hose heater. you might want to consider that one if that hose is easily accessible.

http://www.autozone.com/autozone/acc...eater/_/N-26lg

some examples.

bbo is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission swap for 1998 Nissan Sentra Snav Automotive Repairs 1 03-19-2012 11:11 AM
New Car Engine Sends Shock Waves Through Auto Industry Snav Off Topic 8 01-12-2012 08:29 AM
Transmission Fluid sweaty Automotive Repairs 5 09-07-2010 08:35 PM
DIY Question - 2000 Ford Explorer diyford Automotive Repairs 4 01-13-2010 03:20 PM
Transmission chevy motor automatic sharlani Automotive Repairs 6 07-23-2009 10:39 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.