Ply Voyager Rough Engine - Automotive Repairs - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Do It Yourself > Automotive Repairs

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 09-19-2008, 02:34 AM   #1
wheatski
 
Join Date: Sep 2008
Location: CO
Posts: 3
Rewards Points: 10
Send a message via AIM to wheatski
Question

Ply Voyager rough engine


My 99 Grd Voyager (3.0 3 spd w/ovrdrv) starts and runs but about jumps out of the vehicle and knocks like crazy and won't excelerate (rev up) - it just goes wwwhhhhaaaaaa and won't speed up. It's like it stays choked or overfueled or spark advance is stuck in full advance from start up. The only time it doesn't do this and comes out of it and runs normally is in the early morning when it's still cold (50 or below). Eventually it levels out and will excelerate fine and is drivable. But when I shut it off and then start it again or it's over 50 in the first place it never levels out and it won't even pull itself down the street. It's like when it's cold the the choking process or fuel mixture change for cold start kicks in and changes something so it works right. Otherwise, the "level out" process doesn't happen and it just won't run right. Since it works some of the time I don't suspect a sensor but that could be intermittant too. I suspect more some control that changes idle speed or fuel mix is malfunctioning when it gets a signal to change or the signal is never being sent. Or I have an intermittant problem in the computer!!!
Anybody got any ideas?
Thanks,
wheatski

Advertisement

wheatski is offline   Reply With Quote
Old 09-19-2008, 03:51 AM   #2
Oldguy
 
Rehabber's Avatar
 
Join Date: Dec 2005
Location: Calif (the left coast)
Posts: 498
Rewards Points: 250
Default

Ply Voyager rough engine


Is the 'check engine' light on? How many miles are on this car? When was it last tuned up?

Advertisement

__________________
If you think you can, or if you think you can't, you're probably right.

ASE certified master auto tech, Retired.
Rehabber is offline   Reply With Quote
Old 09-19-2008, 11:52 AM   #3
Custom Cabinet Maker
 
Join Date: Jun 2007
Location: Netcong NJ
Posts: 1,097
Rewards Points: 500
Default

Ply Voyager rough engine


computer chip? That controls everything, yes everything
skymaster is offline   Reply With Quote
Old 09-19-2008, 01:55 PM   #4
I have gas!
 
Clutchcargo's Avatar
 
Join Date: Mar 2007
Location: Massachusetts
Posts: 1,783
Rewards Points: 1,018
Default

Ply Voyager rough engine


Some possibilities are
vacuum leak
EGR valve is stuck.
Fuel filter clogged.
Fuel pump on it's way out.

Read the codes that are in the computer.
__________________
I tear things down and build them up.
Clutchcargo is offline   Reply With Quote
Old 09-19-2008, 02:49 PM   #5
Member
 
47_47's Avatar
 
Join Date: Sep 2007
Location: Springville, NY
Posts: 1,517
Rewards Points: 622
Default

Ply Voyager rough engine


Quote:
Originally Posted by Clutchcargo View Post
Some possibilities are
vacuum leak
EGR valve is stuck.
Fuel filter clogged.
Fuel pump on it's way out.

Read the codes that are in the computer.
In addition, check the PCV, ECT and IAT. You should also use a scan tool and view the data stream.
__________________
What we've got here is... failure to communicate. Some men you just can't reach. So you get what we had here last week, which is the way he wants it... well, he gets it.
47_47 is online now   Reply With Quote
Old 09-20-2008, 10:57 AM   #6
wheatski
 
Join Date: Sep 2008
Location: CO
Posts: 3
Rewards Points: 10
Send a message via AIM to wheatski
Default

Ply Voyager rough engine


To answer Rehabber, it has 150,000 on it and has not been tuned since I got it a year ago on goverment computer auction and probably wasn't for years before that. It has been running fine for the last year without any problems. Drove it on a 2500 mile trip a couple months ago and no problems. I'm trying to figure out whether to just get a computer module from a bone yard and replace it on the chance that is the issue or spend two or three times as much on a mechanic just to find out its an EGR valve which would be cheaper but way more expensive just to find that out!
Thanks guys!
wheatski
wheatski is offline   Reply With Quote
Old 09-20-2008, 10:59 AM   #7
wheatski
 
Join Date: Sep 2008
Location: CO
Posts: 3
Rewards Points: 10
Send a message via AIM to wheatski
Default

Ply Voyager rough engine


And ya, the check engine light does come on when it is having the problem....
wheatski is offline   Reply With Quote
Old 09-20-2008, 12:12 PM   #8
Custom Cabinet Maker
 
Join Date: Jun 2007
Location: Netcong NJ
Posts: 1,097
Rewards Points: 500
Default

Ply Voyager rough engine


Wheatski: I have a 90 caravan 3.0 liter. I dont know if this will apply to yours but worth checking; There is a built in self test in mine, turn the ignition on and off 3 cycles DO NOT START, just turn key on and off 3 times, on mine the check engine light will flash one or more codes, With the manual it will have those "flash" codes listed and what they mean. If need be get the Chilton for ur car, they have it also.
skymaster is offline   Reply With Quote
Old 09-20-2008, 04:22 PM   #9
Oldguy
 
Rehabber's Avatar
 
Join Date: Dec 2005
Location: Calif (the left coast)
Posts: 498
Rewards Points: 250
Default

Ply Voyager rough engine


Your 99 caravan will not display codes without a scan tool. If you live outside of Calif, you can use a scan tool at Autozone for no charge. The code will give you a good starting point for the diagnosis. It is very unlikely that the ECM (computer) is a problem
__________________
If you think you can, or if you think you can't, you're probably right.

ASE certified master auto tech, Retired.
Rehabber is offline   Reply With Quote
Old 09-24-2008, 12:23 PM   #10
Newbie
 
Join Date: Sep 2008
Location: NM
Posts: 23
Rewards Points: 10
Default

Ply Voyager rough engine


Quote:
Originally Posted by wheatski View Post
My 99 Grd Voyager (3.0 3 spd w/ovrdrv) starts and runs but about jumps out of the vehicle and knocks like crazy and won't excelerate (rev up) - it just goes wwwhhhhaaaaaa and won't speed up. It's like it stays choked or overfueled or spark advance is stuck in full advance from start up. The only time it doesn't do this and comes out of it and runs normally is in the early morning when it's still cold (50 or below). Eventually it levels out and will excelerate fine and is drivable. But when I shut it off and then start it again or it's over 50 in the first place it never levels out and it won't even pull itself down the street. It's like when it's cold the the choking process or fuel mixture change for cold start kicks in and changes something so it works right. Otherwise, the "level out" process doesn't happen and it just won't run right. Since it works some of the time I don't suspect a sensor but that could be intermittant too. I suspect more some control that changes idle speed or fuel mix is malfunctioning when it gets a signal to change or the signal is never being sent. Or I have an intermittant problem in the computer!!!
Anybody got any ideas?
Thanks,
wheatski
First thing that comes to my mind is the O2 sensor, paticularily if it's the heated type. The heated type will have 2 or 4 wires coming out of it. And you problebly have two 02 sensors, one at the exhast manifold and the other further down the exhast.

Granet there could be other wiring/sensor problems and or Engine Controll Modle...

i'd go to your dealer and ask them for a print out of any Technical service Bulletens related to your make and modle, and or any recalls that might be covered for free!!!!!

Advertisement

sssalas is offline   Reply With Quote
Reply

Tags
choking , knocking , overfueling


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kawasaki FE-350 11.5hp 4 stroke engine wings3630 Landscaping & Lawn Care 2 08-05-2008 07:08 AM
shower rough in frusteration! Lmiller Plumbing 5 03-13-2008 01:24 PM
Engine Slowly Loses Power and Dies While Driving slickshift Automotive Repairs 16 01-15-2007 12:34 PM
Small engine problem rkhpapa General DIY Discussions 1 12-09-2006 09:00 PM




Top of Page | View New Posts