DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Automotive Repairs (http://www.diychatroom.com/f46/)
-   -   99 dodge 1500 won't idle (http://www.diychatroom.com/f46/99-dodge-1500-wont-idle-150559/)

ben's plumbing 07-17-2012 07:50 AM

99 dodge 1500 won't idle
 
changed starter in truck....everything was fine for a day...battery went dead son said he left overhead lite on...jumped truck started ok leave off gas dies...start it up rev engine everything seems ok leave off gas dies...any help

Mort 07-17-2012 10:55 AM

I had an old Camaro where, after you disconnected the battery or it died, you'd have to drive it around for a few minutes above 35mph to get the computer to reset. It wouldn't idle at all before it did that.

DexterII 07-17-2012 12:52 PM

My first thought would be a vacuum leak. Obviously start with the areas where you were working, to see if you may have inadvertently dislodged a line or something, but, otherwise, and although coincidental if that were the case, intake manifold leaks are not all that uncommon.

ben's plumbing 07-17-2012 07:30 PM

up date....took battery to advanced auto to have checked...they said it was to low needed charged.....they charged it and said battery was good....reinstalled in truck...everything is working fine:eek::eek::eek:

oh'mike 07-17-2012 07:33 PM

Good--computer would have reset after battery had recharged----If you have further trouble--see my PM---

Windows on Wash 07-18-2012 10:38 AM

Quote:

Originally Posted by ben's plumbing (Post 967788)
changed starter in truck....everything was fine for a day...battery went dead son said he left overhead lite on...jumped truck started ok leave off gas dies...start it up rev engine everything seems ok leave off gas dies...any help

At idle, most alternators are only supply just enough to keep the battery topped off and electrical powered.

Not uncommon for the ignition to draw from the battery at idle.

DrHicks 07-18-2012 10:59 PM

Quote:

Originally Posted by ben's plumbing (Post 967788)
changed starter in truck....everything was fine for a day...battery went dead son said he left overhead lite on...jumped truck started ok leave off gas dies...start it up rev engine everything seems ok leave off gas dies...any help

The ECM needs to readjust itself. You should be fine, given several more frustrating days of it dying at idle.

TWX 07-20-2012 10:19 AM

Quote:

Originally Posted by DrHicks (Post 969145)
The ECM needs to readjust itself. You should be fine, given several more frustrating days of it dying at idle.

That computer reacts to that significantly more quickly than that. Worst case the vehicle wouldn't shift as timely as the driver expects and might lack a little power.

I agree that it's most likely that the ignition wasn't getting enough power at idle to keep the truck running.

It could also be a sign of a weak alternator, so bear that in mind.

DrHicks 07-20-2012 10:23 AM

Quote:

Originally Posted by TWX (Post 970169)
That computer reacts to that significantly more quickly than that. Worst case the vehicle wouldn't shift as timely as the driver expects and might lack a little power.

I agree that it's most likely that the ignition wasn't getting enough power at idle to keep the truck running.

It could also be a sign of a weak alternator, so bear that in mind.

Right. It certainly SHOULDN'T take it anywhere near that long to adjust.

oldgoat82 07-24-2012 09:01 PM

My 97 used to do the same thing when the batt voltage dropped. The ECM loses part of the code And the truck will run poorly. Disconnect the batt for at least 15 mins to allow all capacitors to discharge. Reconnect and jump to start or start with a new batt if needed. Then you gotta for a ride so that the ECM re-learn all engine parameters. Good luck.


All times are GMT -5. The time now is 12:22 PM.