93 Chevy 1500 Problems - Automotive Repairs - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Do It Yourself > Automotive Repairs

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 10-06-2010, 11:26 PM   #1
Newbie
 
Join Date: Oct 2010
Posts: 6
Rewards Points: 10
Default

93 chevy 1500 problems


I have a 1993 chevy 1500 an it seems to be running rich. After running it for awhile it gets short on power and misses an when idleing it also sounds funny and i dont know if its somthing with the tbi or in the motor itself. The exhaust an oil smell rich with gas an i've resently changed the air filter, spark plugs,plug wires,distributer cap an rotor,an oil and oil filter.. what could it be?

Advertisement

Coreystultz is offline   Reply With Quote
Old 10-07-2010, 01:36 PM   #2
Newbie
 
Join Date: Oct 2010
Posts: 6
Rewards Points: 10
Default

93 chevy 1500 problems


Oh an the service engine light comes on every once in awhile also.

Advertisement

Coreystultz is offline   Reply With Quote
Old 10-07-2010, 06:30 PM   #3
Member
 
Bigplanz's Avatar
 
Join Date: Apr 2009
Location: Louisville KY
Posts: 525
Rewards Points: 518
Default

93 chevy 1500 problems


Quote:
Originally Posted by Coreystultz View Post
Oh an the service engine light comes on every once in awhile also.
See if you can pull a code. I think on a 93 you ground the test terminal on the ADLI block to get the code to flash. CHECK IF THIS IS THE CORRECT PROCEDURE BEFORE YOU TRY IT!

I would bet it's an O2 or EGR code. You might just have vacuum leak, so check your vacuum lines.
Bigplanz is offline   Reply With Quote
Old 10-07-2010, 07:28 PM   #4
Newbie
 
Join Date: Oct 2010
Posts: 6
Rewards Points: 10
Default

93 chevy 1500 problems


alright i'll give that a try an let ya know if it thats the problem.
Coreystultz is offline   Reply With Quote
Old 10-07-2010, 08:24 PM   #5
Member
 
Bigplanz's Avatar
 
Join Date: Apr 2009
Location: Louisville KY
Posts: 525
Rewards Points: 518
Default

93 chevy 1500 problems


Quote:
Originally Posted by Coreystultz View Post
alright i'll give that a try an let ya know if it thats the problem.
I guess I should have added: just because it is an O2 or EGR code doesn't mean that those sensors are bad. Throwing a code on those (in particular) can mean a bad injector, fuel pressure regulator, or a bad TBI throttle body to intake manifold gasket. If this truck has a 220 TBI it could be a gasket. They had a tendency to develop leaks over time.
Bigplanz is offline   Reply With Quote
Old 10-07-2010, 10:42 PM   #6
Newbie
 
Join Date: Oct 2010
Posts: 6
Rewards Points: 10
Default

93 chevy 1500 problems


Yeah it does have a 220 tbi. I did jus notice that when i hit the gas it doesnt evenly mist out of the injectors its more like spirts and gas builds up in both barrels of the throttle body. Could it be bad injectors or o-rings?
Coreystultz is offline   Reply With Quote
Old 10-08-2010, 06:50 AM   #7
Member
 
Bigplanz's Avatar
 
Join Date: Apr 2009
Location: Louisville KY
Posts: 525
Rewards Points: 518
Default

93 chevy 1500 problems


Quote:
Originally Posted by Coreystultz View Post
Yeah it does have a 220 tbi. I did jus notice that when i hit the gas it doesnt evenly mist out of the injectors its more like spirts and gas builds up in both barrels of the throttle body. Could it be bad injectors or o-rings?
You have a bad injector. Fortunately, they are pretty easy to replace on the 220. Just be careful not to drop anything into the throttle body or you can end up having to take the intake manifold off to get it out.

Advertisement

Bigplanz is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Square D Subpanel bltglt507 Electrical 16 12-04-2009 09:44 PM
Multiple problems in 3 year old house I just purchased swenard Plumbing 12 08-31-2009 04:53 PM
How to diagnose problems with wall kahlan General DIY Discussions 5 10-22-2008 10:18 AM
Elec short causing A/C problems or A/C problems causing elec problems? Marlon Electrical 2 06-25-2008 03:04 PM
Are you having ice problems? Grumpy Roofing/Siding 27 02-17-2008 04:51 PM




Top of Page | View New Posts