DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Automotive Repairs (http://www.diychatroom.com/f46/)
-   -   2 cycle engine no spark (http://www.diychatroom.com/f46/2-cycle-engine-no-spark-108229/)

walkinman 06-18-2011 08:25 PM

2 cycle engine no spark
 
I've got an old Mac 2816 that has no spark. Initially I tried changing the spark plug with no result. Next I disconnected the kill switch, (which had a small fray on the insulation of the wire going to it. I still got no spark when I cranked it. At this point I suspected either a worn or sheared flywheel key or a faulty ignition module. Both the key, and the keyway were in good shape, showing no wear, or deformity. Finally I was able to find a new ignition module for the machine, (no small feat in itself), but after swapping out the old one, I still have no spark.
Since I had the recoil start housing off the machine I spun the engine using an industrial electric dril at approx 175 rpm.
It's a pretty simple circuit, with no interlocks or anything that I'm aware of. As a result, I'm stumped. Does anyone out there have any new ideas I can try?

DexterII 06-20-2011 10:44 AM

Not sure, but I'm thinking that the "kill switch" is simply a ground, so you disconnected it, but did you repair or replace the frayed wire? If not, it seems that could be your problem.

rustyjames 06-20-2011 06:25 PM

It's also possible that you bought a defective module. Just because it's new doesn't mean it's good :thumbsup:

oldrivers 06-20-2011 11:12 PM

when you say ignition module do you mean coil? if so did you use a feeler gauge to set the gap from the magneto to coil?


All times are GMT -5. The time now is 11:43 AM.