Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Painting

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-19-2009, 04:00 PM   #1
Newbie
 
Join Date: May 2009
Posts: 20
Share |
Default

what am I doing wrong?


argh.. I just finished priming a 10x11x8' room (approx 500 sqft paintable area)... it took me 5 hours, and 2.5ga of Zinssers 123 primer. The room was previously painted a light off-white color, but we had the whole house retextured with a light orange peel... so I'm hoping this has something to do with it. They floated all the drywall, and then sprayed on the orange peel, and now I just finished priming a room.

Here is what I am doing in general:
- Using a 2.5" angle brush to cut in the all the wall/ceiling edges and closet/door trim
- The door trim and closet trim wasn't retextured, and it was previously painted with an oil-based paint, so I lightly sanded and primed all of the trim with the brush. The primer applied A LOT easier on the trim; again, I'm hoping it's because of the texturing
- Roll everywhere else with Wooster 1/2" roller cover. I immerse the roller completely in the primer bucket, then roll against the tracks a few times to event out hte paint, and then apply in a W pattern on the walls.

After all of that, I'm left with a half bucket of primer and wondering what I'm doing wrong...

jdhar is offline   Reply With Quote
Old 06-19-2009, 05:17 PM   #2
Member
 
Join Date: Jan 2009
Location: South of Boston, MA
Posts: 17,248
Default

what am I doing wrong?


What do you mean?
What is the problem?

Scuba_Dave is offline   Reply With Quote
Old 06-19-2009, 05:46 PM   #3
Newbie
 
Join Date: May 2009
Posts: 20
Default

what am I doing wrong?


Sorry if I didn't make it clear.. I have read everywhere that 1ga of primer should cover 4-500 sqft, and I am using double that.
jdhar is offline   Reply With Quote
Old 06-19-2009, 06:08 PM   #4
the Musigician
 
DangerMouse's Avatar
 
Join Date: Jul 2008
Location: I'm right here!
Posts: 10,404
Default

what am I doing wrong?


well it should....under IDEAL CONDITIONS, which you did not have.
not your fault.....

DM
__________________
[SIGPIC][/SIGPIC]Click here to see some of my original magic tricks and trick boxes!
DangerMouse is offline   Reply With Quote
Old 06-19-2009, 08:20 PM   #5
Newbie
 
Join Date: May 2009
Posts: 20
Default

what am I doing wrong?


k, guess I thought newly textured walls was as ideal as it gets... guess I was wrong

One more question; is primer supposed to go on as evenly and smoothly as normal paint? I see tons of lines after the primer has dried... but I applied my two coats of BM Regal and it looks fine. Just wondering if I should expect the same even-ness with the primer..
jdhar is offline   Reply With Quote
Old 06-19-2009, 09:46 PM   #6
Member
 
Join Date: Jan 2009
Location: South of Boston, MA
Posts: 17,248
Default

what am I doing wrong?


I generally see thru primer
Primers main objective (I think) is to make sure that the cover coat can stick to whatever is under the primer
Scuba_Dave is offline   Reply With Quote
Old 06-19-2009, 10:33 PM   #7
Newbie
 
Join Date: May 2009
Posts: 20
Default

what am I doing wrong?


cool, thx guys
jdhar is offline   Reply With Quote
Old 06-19-2009, 11:35 PM   #8
Member
 
Matthewt1970's Avatar
 
Join Date: Sep 2008
Posts: 1,766
Default

what am I doing wrong?


That primer is soaking in and sealing the surface. If you were to put a second coat of primer on then you would probably see the right square footage on coverage.

Matthewt1970 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for a step by step for framing basement walls/2x4's wrong direction/stairs??? xray328 Remodeling 27 06-19-2011 08:50 PM
What did i do wrong? - Outlet install trips breaker nymex Electrical 22 05-07-2009 02:44 PM
replaced 3way toggle with rocker switch - what's wrong? ellabo Electrical 8 09-22-2008 04:16 PM
New Compressor - Wrong Charge? shayneb HVAC 4 08-23-2008 08:13 AM
Replacing wrong color grout - 900 SF of tile Lonidier Flooring 5 07-17-2008 04:50 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.