DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Painting (http://www.diychatroom.com/f4/)
-   -   Tank will not build up more than 40lbs! (http://www.diychatroom.com/f4/tank-will-not-build-up-more-than-40lbs-126967/)

64tbirdJerry 12-18-2011 05:26 PM

Tank will not build up more than 40lbs!
 
I bought a CH vertical WL6700 series compressor about six months ago. It worked ok for a while, but recently, it will only build up pressujre to a max of 40lbs. I checked all the air lines; no leaks. I thought it may be the check valve, so i replaced it. With the new check valve, it would build no pressure at all. I removed the large spring from the check valve; you (still) get good air in the spray hose, but no more than 40lbs in the tank. I'm about to pitch this thing if i can't figure out what is wrong. When new, it would build to about 120lbs. I also checked the belt (it's new). If you blow into the check valve with the primary button depressed, air will go out the spray hose outlet no problem. You only get about 33% or air coming out the inlet that fills the tank. I can't belive i could have two faulty check valves in a row, so i must be missing something. BTW, when the pump is running, i can barely hold my thumb on the outlet from the pump - so the output from pump seems strong. HELP!

Brushjockey 12-18-2011 05:40 PM

You might do better on the carpenter forum- very few painters use a conventional spray set up with regular air compressors anymore.

jschaben 12-18-2011 06:03 PM

Quote:

Originally Posted by 64tbirdJerry (Post 796912)
I bought a CH vertical WL6700 series compressor about six months ago. It worked ok for a while, but recently, it will only build up pressujre to a max of 40lbs. I checked all the air lines; no leaks. I thought it may be the check valve, so i replaced it. With the new check valve, it would build no pressure at all. I removed the large spring from the check valve; you (still) get good air in the spray hose, but no more than 40lbs in the tank. I'm about to pitch this thing if i can't figure out what is wrong. When new, it would build to about 120lbs. I also checked the belt (it's new). If you blow into the check valve with the primary button depressed, air will go out the spray hose outlet no problem. You only get about 33% or air coming out the inlet that fills the tank. I can't belive i could have two faulty check valves in a row, so i must be missing something. BTW, when the pump is running, i can barely hold my thumb on the outlet from the pump - so the output from pump seems strong. HELP!

Brush is right, maybe get a mod to move this for you.
Does it build to 40 lbs and shut off or get to 40 and keep running but not get any higher?

user1007 12-18-2011 07:37 PM

You have bled the tank?

joecaption 12-18-2011 10:34 PM

I've never seen a compressor with a check valve, are you sure your not messing with the pressure regulator or the safty pop off?
Several times when I had the problum your having it's the line from the tank to the pressure regulater that's came off or has a hole in it. (some have no line and are connected directly to the tank)


All times are GMT -5. The time now is 05:38 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved