Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Community > Off Topic

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-29-2008, 11:17 AM   #1
Newbie
 
Join Date: Mar 2008
Posts: 1
Share |
Default

Hoover Vacuum


Has anyone had problems with the Hoover Windtunnel II? Mine clogs every time I use it.
peggy925 is offline   Reply With Quote
Old 04-15-2008, 06:07 AM   #2
Newbie
 
Join Date: Apr 2008
Posts: 3
Default

Hoover Vacuum


No, I don't have problems with my vacuum. I suggest checking out the tubes if there are any dust stucked into it.
aaron_man is offline   Reply With Quote
Old 04-15-2008, 07:01 PM   #3
Newbie
 
Join Date: Apr 2008
Posts: 1
Default

Hoover Vacuum


I have central vacuum now, but I do recall that I had to clean out filters and containers every once and a while on my cylinder vacuum.
GarryVernne is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Repairing Electric Central Vacuum Hose jogr Appliances 6 11-11-2008 12:59 PM
Low voltage to vacuum l.schrankel@comcast.net Electrical 2 03-04-2007 09:38 AM
re-routing central vacuum pipe yummy mummy Building & Construction 2 12-03-2006 04:30 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.