Need Help W/ Toro Snowblower - Tools - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Equipment & Safety > Tools

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 02-14-2008, 10:01 AM   #1
Newbie
 
Join Date: Feb 2008
Posts: 1
Rewards Points: 10
Default

Need help w/ Toro snowblower


I have a Toro 8hp snowblower that recently started to run poorly.
It seems to pulsate between normal and very low RPM's, back and forth....I'd say every 2 seconds. Also, the exhaust is kind of black, and it's been stalling under load. I messed around with the screw under the carb bowl a little, and it seemed to help for awhile, but went back to running poorly.
Any ideas?? Thanks.

Advertisement

Rigby is offline   Reply With Quote
Old 02-14-2008, 03:03 PM   #2
Member
 
Join Date: Mar 2006
Posts: 2,083
Rewards Points: 1,000
Default

Need help w/ Toro snowblower


How old is the spark plug?
How old is the gas?
Does this unit sit outside or inside?

Advertisement

redline is offline   Reply With Quote
Old 02-14-2008, 05:23 PM   #3
Master General ReEngineer
 
Bondo's Avatar
 
Join Date: Dec 2007
Location: Chaumont River, Ny.
Posts: 3,833
Rewards Points: 2,300
Default

Need help w/ Toro snowblower


Ayuh,...

It sounds like the Carb is full of Crap,.....
Try Cleaning the bowl out......
Bondo is online now   Reply With Quote
Old 02-15-2008, 02:38 PM   #4
Member
 
Join Date: Jan 2008
Location: So. IN.
Posts: 161
Rewards Points: 150
Default

Need help w/ Toro snowblower


do normal service on it ,, air filter , plug,, etc then reajust the carb correctly (bowl cleaned)
comp is offline   Reply With Quote
Old 02-17-2008, 09:44 AM   #5
Member
 
Join Date: Nov 2007
Location: Scottsdale, AZ
Posts: 331
Rewards Points: 250
Default

Need help w/ Toro snowblower


Check for a restricted exhaust. Sounds like backpressure, possibly a bad muffler.
End Grain is offline   Reply With Quote
Old 02-17-2008, 09:49 AM   #6
Member
 
Join Date: Jan 2008
Location: So. IN.
Posts: 161
Rewards Points: 150
Default

Need help w/ Toro snowblower


Quote:
Originally Posted by End Grain View Post
Check for a restricted exhaust. Sounds like backpressure, possibly a bad muffler.
they can get a build up in them

Advertisement

comp is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ariens snowblower traction skidad Tools 2 12-17-2007 05:32 PM
Toro SnowBlower 521 metallic sound mteach General DIY Discussions 1 12-13-2007 01:27 PM
Toro 521 electric starter repair hwm General DIY Discussions 4 12-12-2007 10:28 PM
Toro Snowblower problem mbgrdido Tools 3 12-07-2007 11:28 AM
Replacing a Snowblower belt Niagarafalls General DIY Discussions 3 12-04-2007 06:53 PM




Top of Page | View New Posts