Go Back   DIY Chatroom Home Improvement Forum > Equipment & Safety > Tools

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-23-2009, 07:45 PM   #1
Member
 
Join Date: Apr 2008
Location: Western Masschusetts
Posts: 575
Rewards Points: 0
Share |
Default

compressor stopped working!


I have a relatively new Makita MAC2400. It's been a delight for a good year or so and never given me any troubles. Have probably only used it a dozen times for a few hours or so.

Well, had it fired up yesterday, filled, turned out I didn't get as far as I needed to, turned it off and drained it.

Today turned it back on, pressurized it, and left it to sit for a few hours.

I used the blowgun attachment to clean some dust off, and it didn't repressurize. Tried multiple different outlets and cords, turned it on and off, fiddled with the regulator control, nothing. Just woulldn't turn on.

Saw the oil was looking a little sludgy, and low. Added a bit to it, and brought it inside about an hour ago to warm up.

Still doesn't turn on!

Any ideas what is going on? It hasn't been banged up or dropped or anything. Nothing that would have caused the wiring to disconnect or anything like that.

No idea. need this to work!

Thanks.

wombosi is offline   Reply With Quote
Old 02-23-2009, 08:00 PM   #2
Member
 
Join Date: Apr 2008
Location: Western Masschusetts
Posts: 575
Rewards Points: 0
Default

compressor stopped working!


sorry guys. just fixed it.
found the manual online.
turns out there is some kind of thermal overload "reset" button. was able to find it andpush it, and all is well again!

yay.

wombosi is offline   Reply With Quote
Old 02-25-2009, 11:54 PM   #3
Member
 
Join Date: Jan 2009
Posts: 34
Rewards Points: 0
Default

compressor stopped working!


Here is a question....did you ever break in the compressor? Did you ever change the oil? If so what did you use for oil, what Makita reccomeneded...
TBFghost is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No heat but working AC xevier69 HVAC 4 01-30-2009 05:31 PM
Two switch in one box: only one working jdtsmith Electrical 12 09-29-2008 01:32 PM
Inside Fan not working BenH HVAC 20 07-08-2008 06:10 AM
GE fridge evaporator fan change and still not working Trish Appliances 2 03-30-2008 01:47 PM
Furnace stops working once a day - help Da_Bears HVAC 2 01-26-2006 01:19 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.