Go Back   DIY Chatroom Home Improvement Forum > Equipment & Safety > Tools

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-09-2010, 11:46 AM   #1
Member
 
Join Date: Mar 2010
Location: Calgary, Alberta, Canada
Posts: 64
Share |
Default

CampBell Hausfeld Compressor problems


Hi Guys,
I just recently bought a used 20G 5HP Campbell Hausfeld compressor, vertical tank, the compressor runs ok, the tank holds its air/compression fine, the pressure does not drop even after a week of no use.

The problem I find with the compressor is: when there is a pressure in the tank that is higher than ~40 psi, the pump will not restart, when I turn it on, it will try to rotate a couple of rounds then stops, then the motor makes this huuum sound, and if I leave the switch at ON position for several more seconds, my fuse at the panel will jump.

However, if I "drain" the air out, and drop the tank pressure to ~20 psi or lower, then I can restart it no problem, and it will compress all the way to >110 psi.

So, I guess the pump and the motor are good, and there is something wrong with the control module, the thing that sits on top of the tank, with the ON/OFF switch, what is it called?

What do you think the problem is with the compressor? Is this something I can fix?

Thanks!

Hexar is offline   Reply With Quote
Old 10-10-2010, 07:05 AM   #2
Household Handyman
 
Join Date: Feb 2009
Location: Albany, Ga.
Posts: 2,270
Default

CampBell Hausfeld Compressor problems


Drain the tank completely. Start the unit up and allow to run until it shuts down by itself then be near the unit to note: 1) Do you hear a small amount of air released from the control box or very near it? 2) At what tank pressure does it shut down (cut-out pressure)? If you do not hear this small amount of air when the unit shuts down, then the "unloader" is not allowing the residual amount of air to be released between the compressor unit and the check valve of the unit. OR: IF you do hear this air escape, try releasing air from the tank via the drain valve quickly until the unit tries to start back up and note this pressure (cut-in pressure). IF the unit does start back up, then you have a check valve problem. IF the unit does not start back up with releasing air from the drain valve rapidly, the check valve is most likely good, so back to the unloader. The unloader allows air to be released between the check valve and compressor unit so the compressor does not try to "dead-head" when starting, which it sounds as if your's is doing. This is usually controlled by an solenoid type valve within the controller itself. When the unit st0ps, the valve opens and the air escapes. IF this valve is not working it will not allow the air to escape.

Thurman is offline   Reply With Quote
Old 10-11-2010, 09:11 PM   #3
Member
 
Join Date: Mar 2010
Location: Calgary, Alberta, Canada
Posts: 64
Default

CampBell Hausfeld Compressor problems


Thurman,
Thanks a lot for the detailed message, I will try your methods and report back.

Cheers,
Hex
Hexar is offline   Reply With Quote
Old 10-13-2010, 08:37 PM   #4
Newbie
 
Join Date: Jul 2010
Posts: 8
Default

CampBell Hausfeld Compressor problems


I had the same issue with an older compressor recently. On the motor there are two capacitors, one a run capacitor and the other a start. You most likely have a shorted start capacitor, since the motor is drawing too much current when starting with a load. Look online for steps for testing a capacitor. I used the fuse method for testing mine.
whiteblur is offline   Reply With Quote
Old 10-13-2010, 08:41 PM   #5
nap
You talking to me?
 
nap's Avatar
 
Join Date: Dec 2007
Location: sw mi
Posts: 5,407
Default

CampBell Hausfeld Compressor problems


Quote:
Originally Posted by whiteblur View Post
I had the same issue with an older compressor recently. On the motor there are two capacitors, one a run capacitor and the other a start. You most likely have a shorted start capacitor, since the motor is drawing too much current when starting with a load. Look online for steps for testing a capacitor. I used the fuse method for testing mine.
the fact that the OP's compressor starts fine with no pressure in the tank but once there is pressure, the motor has problems. That is more indicative of a malfunctioning pressure relief system.

If there is a bad capacitor, it will generally be a problem all the time. The fact is; there should be no load on the motor/compressor because the pressure relief system releases the pressure on the compressor so there is no load.
nap is offline   Reply With Quote
Old 10-20-2010, 09:31 PM   #6
Remodeling Contractor
 
Join Date: Oct 2009
Location: Minneapolis, MN
Posts: 86
Default

CampBell Hausfeld Compressor problems


I have had issues with electric compressors like this before and for me, it has always been the source of power. You probably need to plug into a higher amperage circuit.

When the tank is empty, the motor has little resistance against it during startup. The draw from the circuit is at its minimun during the compressors cycle. As the pressure builds, so does the draw from the circuit. However, the initial load from startup is no longer an issue.

When the compressor starts with pressure already in the tanks, the motor needs high amps to start, and that load is increased due to increased resistance from the pressure already built in the tanks.

The compressor being cold will magnify the problem.

Try getting your compressor to room temp before using it, don't use an extension cord with your compressor, and plug into a higher amp circuit.
eisert is offline   Reply With Quote
Old 10-20-2010, 09:35 PM   #7
nap
You talking to me?
 
nap's Avatar
 
Join Date: Dec 2007
Location: sw mi
Posts: 5,407
Default

CampBell Hausfeld Compressor problems


Quote:
Originally Posted by eisert View Post

When the compressor starts with pressure already in the tanks, the motor needs high amps to start, and that load is increased due to increased resistance from the pressure already built in the tanks.
.
Not if there is a pressure relief system. That removes all of the pressure from the compressor once the motor stops. That way there is no load on the compressor. Small compressors often do not have them. When you get into stationary compressors, they become more prevalent and on large compressors, a standard item.
nap is offline   Reply With Quote
Old 10-20-2010, 09:41 PM   #8
Remodeling Contractor
 
Join Date: Oct 2009
Location: Minneapolis, MN
Posts: 86
Default

CampBell Hausfeld Compressor problems


Since a 20 gallon 5 hp compressor isn't that big, and Campbell Hausfield are generally no-frills compressors, I'm guessing no pressure releif valve. Not saying I'm right, but when my electric compressors won't run right, it's almost always the power source.
eisert is offline   Reply With Quote
Old 10-20-2010, 10:20 PM   #9
nap
You talking to me?
 
nap's Avatar
 
Join Date: Dec 2007
Location: sw mi
Posts: 5,407
Default

CampBell Hausfeld Compressor problems


Quote:
Originally Posted by eisert View Post
Since a 20 gallon 5 hp compressor isn't that big, and Campbell Hausfield are generally no-frills compressors, I'm guessing no pressure releif valve. Not saying I'm right, but when my electric compressors won't run right, it's almost always the power source.
of course, you could be right as well. Just having a bad night and not presenting myself well. My apologies.

If there is no unloader, yes, it could absolutely be something as simple as an undersized conductor for the load. The breaker presumably is large enough as it does not trip until the motor is stalled for some time. He could simple be experiencing a voltage drop caused by undersized circuit conductors.
nap is offline   Reply With Quote
Old 10-21-2010, 08:43 AM   #10
Member
 
Join Date: Jul 2010
Posts: 1,737
Default

CampBell Hausfeld Compressor problems


Virtually all air compressors will show a significant increase in current draw on startup, simply due to the fact that there is a lot of mass to put in motion, so that is a factor, regardless of whether the it is unloaded, or not. On the other hand, in terms of the types of air compressors that would typically come up for discussion on a DIY forum, virtually all of them, including Campbell Hausfeld, would have some manner of unloading, whether a sophisticated system based on oil pressure, a simpler centrifugal based system, or the more basic system utilizing a "load genie" or some such device. The op hasn't returned for a bit, but while he should definitely check or recheck his wiring, to ensure that it is adequate, based on his description, I am inclined to agree with those who suspected a faulty unloader.
DexterII is offline   Reply With Quote
Old 10-22-2010, 01:46 PM   #11
Mold!! Let's kill it!
 
Join Date: Feb 2008
Location: Central Pennsylvania
Posts: 2,843
Default

CampBell Hausfeld Compressor problems


My 3 horse CH has an unloader. I'm guessing that a 5 HP would have one too. First thing I would check since they can load with dirt and moisture.
Maintenance 6 is offline   Reply With Quote
Old 11-13-2010, 07:07 PM   #12
And Still Learning
 
Join Date: Nov 2010
Location: WAR EAGLE
Posts: 114
Default

CampBell Hausfeld Compressor problems


This thread is what lead me to this site. I searched "campbell hausfeld 20 gallon" and wound up here. So I joined.

I have this same 3 week old belt driven unit that will not start when below 55F and the tank has more than 25psi. Once it does run I can hear the unloader hiss when it cycles off. I have not checked for a leaky check valve. I was dissapointed when saw made in chiner on my new compressor. This is a capable unit that is quiter than most. After proper break in I ran the break in oil for 2 hours then changed the oil. Used the mobile one 10-30 synthetic. The high dollar oil did not help with starting.
Know It ALL is offline   Reply With Quote
Old 11-13-2010, 10:18 PM   #13
Safe, Most of the Time!!
 
brokenknee's Avatar
 
Join Date: Dec 2008
Location: MN
Posts: 652
Default

CampBell Hausfeld Compressor problems


Quote:
Originally Posted by Know It ALL View Post
This thread is what lead me to this site. I searched "campbell hausfeld 20 gallon" and wound up here. So I joined.

I have this same 3 week old belt driven unit that will not start when below 55F and the tank has more than 25psi. Once it does run I can hear the unloader hiss when it cycles off. I have not checked for a leaky check valve. I was dissapointed when saw made in chiner on my new compressor. This is a capable unit that is quiter than most. After proper break in I ran the break in oil for 2 hours then changed the oil. Used the mobile one 10-30 synthetic. The high dollar oil did not help with starting.
Not to discourage any DIY project, but if it is only 3 weeks old I would bring it back. I have a 20 year old CH 2HP 20 gallon tank and it will start and run when it is -20.
__________________
"Clarity to Agreement" Dennis Prager

Picture/Photo Pitcher/Carafe ------- Where/Someplace Were/Be
brokenknee is offline   Reply With Quote
Old 11-23-2010, 06:23 PM   #14
Member
 
Join Date: Mar 2009
Location: British Columbia Canada
Posts: 460
Default

CampBell Hausfeld Compressor problems


I have had similar problem with my CH compressor and have found that if I turn it off with air in the tank and try to re-start it it was a no go. The solution was simple, the extension cord I was using coupled with other items on the same circuit did not give enough juice. Changed the cord, turned off the air filter and voila, problem solved.
Hope this helps.

fixrite is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Campbell Hausfeld (electric) 1500psi pressure-washer problems Eric VB Landscaping & Lawn Care 0 06-12-2010 04:50 PM
Bostitch VS Campbell Hausfeld nailers. Jim F Tools 4 04-25-2010 01:50 AM
hvlp campbell h. paul moody Painting 0 11-25-2009 02:14 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.