Go Back   DIY Chatroom Home Improvement Forum > Equipment & Safety > Tools

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-12-2013, 02:41 PM   #1
Newbie
 
Join Date: Dec 2013
Location: mason ohio, near cincinnati
Posts: 4
Rewards Points: 0
Share |
Default

air compressor problem


i have a cambell hausfeld 5HP 20 gal electric air compressor that seems to work fine except that when it calls for the compressor to run, the compressor will only rum for about 90 seconds, then shuts off (with the sound of a little air letting off). the only way i can get it to run again is to unplug it, turn it off, and 5 or 10 minutes later plug it back in , & turn it on. then it will run for another 60 - 90 seconds - i do this till it's up to full pressure. then when i use it, the compressor will kick on after about 10 or so lbs of pressure has been used, and i have to keep unplugging it to let something reset to use it again. right now i'm blowing the water out of my sprinkler system and it's taking all day to do 9 zones.
it almost seems like a heat sensor shuts it down. i dont know anything about an air compressor so i've been using it like this for a few years. the local compressor repair place has gone out of business or i'd take it there.
i have tried to search for this problem but i havent been able to understand if other cases match mine, plus i dont understand the explanations. it's not that i'm an idiot, well unless you ask my wife!
any help??

tvsp is offline   Reply With Quote
Old 12-12-2013, 02:46 PM   #2
Member
 
Join Date: Nov 2011
Location: Hartfield VA
Posts: 26,426
Rewards Points: 192
Default

air compressor problem


Please post the model #.

__________________
When posting in forums, letting us know your location will help others give better feedback/advice/solutions to your questions
joecaption is offline   Reply With Quote
Old 12-12-2013, 02:52 PM   #3
Newbie
 
Join Date: Dec 2013
Location: mason ohio, near cincinnati
Posts: 4
Rewards Points: 0
Default

air compressor problem


sure: # WL651100AJ
and already i am wrong - i just turned it off for 5 minutes then back on without unplugging and it ran.
tvsp is offline   Reply With Quote
Old 12-12-2013, 02:54 PM   #4
Exterior Construction
 
Windows on Wash's Avatar
 
Join Date: Aug 2011
Location: VA, MD, DC
Posts: 6,261
Rewards Points: 104
Default

air compressor problem


Is it the overload switch or is the pressure switch bad?

Sound to me like either.
Windows on Wash is offline   Reply With Quote
The Following User Says Thank You to Windows on Wash For This Useful Post:
BigJim (12-12-2013)
Old 12-13-2013, 02:36 PM   #5
Mold!! Let's kill it!
 
Join Date: Feb 2008
Location: Central Pennsylvania
Posts: 2,843
Rewards Points: 0
Default

air compressor problem


Pressure switch is sticking.
Maintenance 6 is offline   Reply With Quote
Old 12-13-2013, 04:26 PM   #6
Newbie
 
Join Date: Dec 2013
Location: mason ohio, near cincinnati
Posts: 4
Rewards Points: 0
Default

air compressor problem


thanks, i'll start there.
tvsp is offline   Reply With Quote
Old 12-18-2013, 09:07 AM   #7
Member
 
Join Date: Aug 2007
Posts: 234
Rewards Points: 0
Default

air compressor problem


Check for water in tank could be ice also Your in a cold climate area Ohio,
deck hand is offline   Reply With Quote
Old 12-18-2013, 11:15 AM   #8
Newbie
 
Join Date: Dec 2013
Location: mason ohio, near cincinnati
Posts: 4
Rewards Points: 0
Default

air compressor problem


yes thanks, i already checked/drained & had less than 1/2 tsp.

tvsp is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.