Go Back   DIY Chatroom Home Improvement Forum > DIY Repair > General DIY Discussions

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-12-2008, 12:17 AM   #1
Newbie
 
Join Date: Jan 2008
Posts: 1
Rewards Points: 10
Question

small engine help


Hi ,,I have two 30cc Ryobi string trimmers that i purchased this past year(2007),, and I amexperiencing the same pronlem from both ...
it seems as I press the small primer ball a few times that it gets full and is not putting any of the gas into the carb for starting..prime a few times ,, no start ,,,, hit carb with a shot of starting fluid , and it starts right away..
I always use clean gas ,, and a good oil mixture , but it seems to be a clog somewhere?
also I think that the factory adjusted carbs are slightly out of adjustment ,, at full throttle squeeze the trimmers bog down,, but if i only squeeze about 3/4 trigger , they speed back up?
why do they cover the adjustment screws so they cant be adjusted?
Any help or ideas would be greatly appreciated!!


bigk3cincy is offline   Reply With Quote
Old 01-12-2008, 07:52 AM   #2
Master General ReEngineer
 
Bondo's Avatar
 
Join Date: Dec 2007
Location: Chaumont River, Ny.
Posts: 3,727
Rewards Points: 2,088
Default

small engine help


Ayuh,........

It sounds like your Gas hasn't been as Clean as you Think it has been.......

You probably need a Carb Kit for each 1, so you can Rebuild the Fuel Delivery System.......

It's Plugged......

Bondo is offline   Reply With Quote
Old 01-12-2008, 04:25 PM   #3
Member
 
Join Date: Nov 2005
Posts: 232
Rewards Points: 150
Default

small engine help


word of caution,,,starting fluid is HARD on these little guys,,,use WD-40,its better FOR it and you. NO ether. IF it runs on WD-40 and not on your gas then gunked up gas is a factr.

One other thing,,,does it have a rubber hose from tank to carb?? And that primer does IT use a rubber hose?? Ethanol is in ALL fuels these days and NOT compatable with some rubber. check to see your getting GOOD flow at the carb. The rubber can and does rot from inside out so maybe inside is closed off and not getting proper amount of fuel. Saw a snow blower where the hose rotted right off and it wasnt OLD either!!

After that drain ALL gas and only use gas less than two weeks or less old,,,modern gas doesnt keep,,,AND use Stabil in it to boot!! can try using seafoam in it to clean out the gunk,cant hurt!!
justdon is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can a DIY build a small in-ground swimming pool? zel General DIY Discussions 14 06-15-2013 10:42 AM
Small engine repair tripower Tools 2 07-09-2009 04:28 AM
Number of circuits needed for a small kitchen? All responses welcome! alexz Electrical 5 04-07-2007 11:38 AM
Engine Slowly Loses Power and Dies While Driving slickshift Automotive Repairs 16 01-15-2007 12:34 PM
Small engine problem rkhpapa General DIY Discussions 1 12-09-2006 09:00 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.