Go Back   DIY Chatroom Home Improvement Forum > DIY Repair > General DIY Discussions

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-12-2010, 09:22 AM   #1
Newbie
 
Join Date: Dec 2010
Posts: 1
Share |
Default

discolored water


I have a Kinetico water treatment system with Culligan sulfur filter. I replaced my old Culligan softner with a Kinetico system I obtained from a friend. The unit has been serviced by Kinetico with all upgrades and new resin. When placed on line for the first time a dark amber lipuid passed throuigh the drain. After that my water in the house was discolored. the Kinetico Tech., who was present, and started the system said it was the result of the new resin and would clear up. It has now been three weeks and the water remains discolored.

If I bypass the softner and let the water flow only through the sulfur filter it will clear up in a couple of days. If I then direct the flow through the softner and sulfur filter the discoloration comes back. Then If I bypass the surfur filter and use the softner only, the water will also clears up in a couple of days. The well water is clear with no discoloratoin.

The Kinetico tech. that installed the kinetico system placed it before the sulfur filter whereas with the Culligan system the sulfur filter had been plumbed-in before the softner. Could this be the problem, or are the two systems just not compatible?

thanks

capt. is offline   Reply With Quote
Old 12-12-2010, 04:01 PM   #2
Newbie
 
Join Date: Dec 2010
Posts: 7
Default

discolored water


Id say u have a faulty sulfar filter

jairoc is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Inside/Around American Standard Furnace michrob HVAC 8 12-08-2011 03:51 PM
Gas Water Heater, water not hot enough - Thermostat or Sediment makunag Plumbing 15 08-27-2010 11:00 PM
Low/No Hot Water Pressure after changing Elements Onehipcat Plumbing 18 08-05-2010 09:16 AM
I ran my well dry and now have discolored water AlaskaPack General DIY Discussions 4 05-19-2009 10:15 AM
Low Hot Water Pressure btennant Plumbing 4 12-09-2008 09:31 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.