DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Electrical (http://www.diychatroom.com/f18/)
-   -   No electricity after turning breaker back on! Need sage advice! (http://www.diychatroom.com/f18/no-electricity-after-turning-breaker-back-need-sage-advice-22298/)

safeTfirst 06-15-2008 02:32 PM

No electricity after turning breaker back on! Need sage advice!
 
I installed a dimmer switch for dining room light. At the switch plate it has two switches; one for the outdoor light and one for the aforementioned dining room.

Did the usual; turn off all swithes at control panel to ensure I had the right one. But after installing and seeing the new dimmer switch in action I noticed the electricity in an adjacent living room does not have power anymore.

I've turned off all the breakers and let it sit for awhile but to no avail. I don't want to pay an electrician to come out and spend two seconds fixing this.

What likely happened? And how do I fix this?

Any input is greatly appreciated.

wirenut1110 06-15-2008 04:31 PM

Sounds like you may have hooked the switch leg from your new switch to the "feed through" leg of this circuit. Some people don't pigtail feed through connections, some do. When you unhooked the 2 wires from your old switch, did you just hook up those 2 back to the dimmer. Either that or when you were in the box, something became loose(especially if the switches were backstabbed and you've lost the circuit to the next room.

safeTfirst 06-15-2008 04:58 PM

Thanks for the response, Wirenut. Some of the jargon is over my head though so I'll do my best to paint a picture.

You ask: "When you unhooked the 2 wires from your old switch, did you just hook up those 2 back to the dimmer?"

Yes. On the old switch, the negative current was connected by its wire to the main wire with that plastic "screw cap". The positive current was connected in the same way, however, the wire going through the wall cavity was not cut but was folded over before being screwed in together. And that folded wire continued on to be connected to the second switch that controls the outside light.

Connecting new dimmer, I "stabbed" the negative into the back of the switch but had to loop the positive around the screw and tighten it (again, because that line is ultimately connected to the second switch on the main panel). The ground wire was connected to the appropriate area, per the instructions.

So, I'll check the connections again. I wonder if the problem is with the way I've connected the positive wire to the new dimmer switch, maybe broke the connection? Doesn't seem logical but then I've got the "newbie" label attached to my profile.


All times are GMT -5. The time now is 12:12 PM.