Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Electrical

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-03-2012, 07:23 PM   #1
Member
 
Join Date: Dec 2010
Posts: 66
Share |
Default

New T8 Light Fixture doesn't work


I had a dying T12 light fixture and since you cant buy new T12 ballasts, I just replaced it with a new 4 Bulb T8 Light Fixture.

Unfortunately this light fixture doesnt work. I hooked up my voltage meter to it and it shows 116 volts at the line going into it. Would 4 volts off cause the light not to fire? Any ideas to try and get it to work?

Edit: In a 4 bulb fixture I do only have 2 bulbs in it. Is that OK, or do I need to have all 4 in?


Last edited by tunaman; 11-03-2012 at 07:34 PM.
tunaman is offline   Reply With Quote
Old 11-03-2012, 08:29 PM   #2
Member
 
joed's Avatar
 
Join Date: Mar 2005
Location: Welland, Ontario
Posts: 7,461
Default

New T8 Light Fixture doesn't work


Try it with all 4 lamps. The T8 fixtures we use do allow removal of lamps. I'm not sure if that is true of all of them.
Another issue could be grounding. Some fixtures require a ground to fire the tube properly.

__________________
Do not PM with questions that can be asked in a forum. I will not respond.
joed is online now   Reply With Quote
Old 11-03-2012, 08:40 PM   #3
Member
 
Join Date: Dec 2010
Posts: 66
Default

New T8 Light Fixture doesn't work


There is a green ground screw in the frame (not hooked to the ballast) but on the fixture I took out it was not hooked up so figured this one would be the same. The instructions dont even mention the ground. There was just black and white wires coming in to the original fixture. There is a ground screwed in to the junction box about 12 feet away.
tunaman is offline   Reply With Quote
Old 11-03-2012, 10:05 PM   #4
Pure Genius
 
Join Date: Jan 2011
Location: Dayton OH
Posts: 223
Default

New T8 Light Fixture doesn't work


Put all lamps in. Some fixtures require all lamps to fire
Dierte is offline   Reply With Quote
Old 11-03-2012, 10:25 PM   #5
Newbie
 
Join Date: Oct 2012
Posts: 21
Default

New T8 Light Fixture doesn't work


Check that it has a 120v ballast inside.
Marc05 is offline   Reply With Quote
Old 11-03-2012, 10:34 PM   #6
Licensed electrician
 
Join Date: Sep 2007
Location: Maryland
Posts: 7,519
Default

New T8 Light Fixture doesn't work


Check the wiring going to the sockets. there is a good chance it needs to be changed. A diagram will be on the ballast.
__________________
Answers based on the National Electrical Code. Local amendments may apply. Check with your local building officials.
Jim Port is offline   Reply With Quote
Old 11-04-2012, 01:04 AM   #7
Member
 
Join Date: Dec 2010
Posts: 66
Default

New T8 Light Fixture doesn't work


I will get 2 more bulbs tomorrow. Im hoping that is the problem. Yes it says in big letters 120 vollts. I know I wired it correctly. I took one look at the wiring and it is obvious. All the prewired wiring is color coded and cut to just the right length. 2 long yellows for the ends, and a red and blue for the middle. And for the power black to black and white to white. I took this fixture out of the box new today.

Thanks guys, I knew I wired it right but I have never really done lighting before so wasnt sure if there was something I might have been missing. If adding 2 bulbs doesnt work tomorrow, im replacing the fixture.
tunaman is offline   Reply With Quote
Old 11-04-2012, 01:31 AM   #8
" Euro " electrician
 
frenchelectrican's Avatar
 
Join Date: Apr 2006
Location: WI & France { in France for now }
Posts: 5,369
Default

New T8 Light Fixture doesn't work


What the ballast part number is on stamped on it so the reason why I can able indentify if you have rapid start or instat start ballast.

Note the rapid start they always wired in series of pairs of bulbs so you will need two bulbs to get one set lit up. The instat start verison will useally wired in either way but most case in parallel mode so any numbers of lamp will get it running.

Again post the number and we will go from there.

Merci,
Marc
__________________
The answer will be based on NEC ( National Electrical code ) or CEC ( Cananda Electrical code ) or ECF ( Electrique Code France )
frenchelectrican is offline   Reply With Quote
Old 11-04-2012, 01:41 AM   #9
Member
 
Join Date: Dec 2010
Posts: 66
Default

New T8 Light Fixture doesn't work


ap rc 432ip 120 - 1 it is labeled instant start ballast.
tunaman is offline   Reply With Quote
Old 11-04-2012, 01:48 AM   #10
" Euro " electrician
 
frenchelectrican's Avatar
 
Join Date: Apr 2006
Location: WI & France { in France for now }
Posts: 5,369
Default

New T8 Light Fixture doesn't work


Quote:
Originally Posted by tunaman View Post
ap rc 432ip 120 - 1 it is labeled instant start ballast.
Parallel connection.

Second thing is check the tombstone to make sure the connection is good some case the conductors can come loose from factory which I have see it once a while.

You will need 4 lamps to get this light up first time.

And try to switch the red et bleu socket around some case it will work.

If that fail to light up then take a test lamp or use the tempory outdoor pigtail light socket and use with 60 watt bulb and hook it up tempory to make sure you actually have good source due some of the DVM ( digial voltmeter ) don't actually put a load on espcally with a bad connection which it will show up.

If your test light don't come on then you have issue with supply you may want to check the connection and splices at the junction box ditto with switch box if the netural is there.

Merci,
Marc
__________________
The answer will be based on NEC ( National Electrical code ) or CEC ( Cananda Electrical code ) or ECF ( Electrique Code France )
frenchelectrican is offline   Reply With Quote
Old 11-04-2012, 02:41 AM   #11
Member
 
Join Date: Dec 2010
Posts: 66
Default

New T8 Light Fixture doesn't work


My connections are all solid. I double checked them when it wasnt working. I have good power all the way up to the leads for the fixture. I bet 2 more bulbs will work.
tunaman is offline   Reply With Quote
Old 11-04-2012, 11:07 AM   #12
Member
 
Join Date: Dec 2010
Posts: 66
Default

New T8 Light Fixture doesn't work


I went and got 2 bulbs today and nope, no go. Put in all 4 bulbs and I do not have light. Im not sure what I could have done wrong but I guess maybe fixture bad.
tunaman is offline   Reply With Quote
Old 11-04-2012, 03:31 PM   #13
Member
 
Oso954's Avatar
 
Join Date: Jun 2012
Location: Northern Calif.
Posts: 1,515
Default

New T8 Light Fixture doesn't work


I think you are overlooking the grounding issue. Some lamps may not start with the ground missing.

Your instructions (step 3) tell you to connect the ground. They mention the ground, before the supply wires.

Maybe you should give Lithonia a call and see if they can help you.
Oso954 is offline   Reply With Quote
Old 11-04-2012, 06:02 PM   #14
Member
 
Join Date: Dec 2010
Posts: 66
Default

New T8 Light Fixture doesn't work


I added a ground wire, just from the ground screw to a nearby junction box with a ground wire and no go.
tunaman is offline   Reply With Quote
Old 11-04-2012, 06:04 PM   #15
Licensed electrician
 
Join Date: Sep 2007
Location: Maryland
Posts: 7,519
Default

New T8 Light Fixture doesn't work


Is the other junction box grounded?

__________________
Answers based on the National Electrical Code. Local amendments may apply. Check with your local building officials.
Jim Port is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to figure out Knob & Tube wiring on old light fixture dalethompson Electrical 16 02-02-2012 08:42 PM
Ceiling fan light fixture doesn't work c4hfam Electrical 9 03-05-2011 01:01 PM
Issues hooking up new light fixture ddzc Electrical 6 11-29-2010 07:19 PM
Light fixture in ceiling fan won't work. Tested DIYself Electrical 7 11-28-2010 11:52 AM
Help with wiring a new light fixture tinkin3 Electrical 10 09-09-2009 09:26 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.