DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   York Diamond 80 won't ignite (http://www.diychatroom.com/f17/york-diamond-80-wont-ignite-91907/)

Softsail2 01-10-2011 03:26 PM

York Diamond 80 won't ignite
 
Our 6 year old heater attempts to ignite and after three tries it gives up, but is still blowing cold air all over the house (it's about 52 inside today - so we turned it off)
I opened the panel, but am not sure what to even start trying to clean or reconnect, any ideas?
thanks

yuri 01-10-2011 04:04 PM

2 Attachment(s)
When it tries to ignite do you see a red glow from the igniter which sits in front of usually the far right burner? There may a viewing window with a flashing Led and error code chart on the front or back of one of the doors or in the owners manual.See if you can get that code. Does it actually ignite the gas and then go out. If so clean the flame sensor with fine emory paper or steel wool. Sits in front of one of the burners and looks like one of these:

Softsail2 01-10-2011 04:25 PM

Diamond 80
 
Hi Yuri,
I'm getting 7 blinks on the red LED through the portal before I shut the thing off (I was getting tired of cold air being blown through the house - down to 49 degrees today - still 6 degrees warmer than outside so I'm relatively happy)
From what it looks like on the panel it's an ignitor problem, no flame, but since the furnace is in the attic and the tstat is in the hall, i have a few steps to climb before I can watch the thing light up.
I'll try to get someone downstairs to set it off while I'm up in the attic next and see what happens.
I'll bring some sandpaper up there just in case.

Softsail2 01-10-2011 08:13 PM

Imagine That!
 
Ok, so I broke down and called one of the 3 ads on Craigs. I picked it because it looked like the company had enough experience and variation of services, but didn't have the huge banner ads or graphics that usually indicate a lot of marketing $$.
Anyhow, this guy Rob shows up about 10 minutes early, meets our dogs spends about 5 minutes fussing around with the furnace, then tells me


"it's a flame sensor that's a little dirty and needs to be cleaned."

10 minutes later he's done, walking out the drive and says, "no charge it was an easy fix"

Wow, not only couldn't I have figured this out myself, but here's a young guy building a business for whenever my low end York product fails again (and you all know it will)

I yelped the guy and his company, plus wrote down their number for when the fan motor, or circuit board fails, then it would probably be better to just get a new furnace, and who are we gonna call!

Rob!

Thanks again Yuri for your pointers, I hope I have returned the favor

dlee300z 02-03-2011 07:42 PM

I'm having the exact same problem. The only thing is I tried cleaning it and it didn't work. I bought another flame sensor (ignitor) and it still did not work.

If I manually light the furnace then it does stay on until I turn the temperature down. UGH! So frustrating.

I was thinking of testing to see if the filters are too dirty? I'm not sure if this would cause the ignitor to not even glow red. It's cool to the touch.

Also, I was going to test to see what voltage it was getting.

Does anyone have anymore suggestions?

yuri 02-03-2011 09:12 PM

The igniter is different than the flame sensor. It should glow red hot and usually runs off 120 volts.

Softsail2 02-04-2011 01:20 AM

I'm not an expert, actually just a consumer, but Yuri's right they are different and if you clean up the sensor it might help the thing fire up like it used to. No other suggestions, that was the issue with ours.

unicursalhex 02-04-2011 01:52 AM

Thats cool that the dude didn't charge. It kinda bums me out because guys giving stuff away for free or dirt cheap hurts the industry. It perpetuates the idea that there's some idiot out there that will work for free. I pay anywhere from $50-200 a week on bogus leads where people are "planning and budgeting" for a furnace maintenance, thermostat, or service. These services fall within a certain range for almost all companies and I'm at the lower end for service rates, yet people are looking for the guy who will do it for nothing. Sorry, I just had to rant a little.

dlee300z 02-04-2011 02:49 AM

Doesn't seem like there's power going to it. Oh well, I didn't fee like climbing up into the attic today.

jabshire 01-19-2012 07:42 AM

York Diamond 80 wont light
 
I had the same problem. Burner wouldn't stay lit. LED blinking 7 times which is the code indicating no flame. However the burners were coming on for 3 tries then staying off. Cleaned the flame sensor, liked Yuri suggested and now the unit is running great. Thanks for the tip, Yuri. :thumbsup:


All times are GMT -5. The time now is 06:05 PM.