Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-23-2009, 10:00 PM   #1
Member
 
Join Date: Mar 2009
Location: Massachusetts.
Posts: 305
Share |
Default

Water Heater Control unit makes noise then shut off...


My water heater is a big blue tank next to my boiler and the only thing I could scrape off it was the name Amtrol. A couple of weeks ago the repair guy came to fix some parts on the boiler(electrical) and he noted that the relay was making a noise which I said it had never done before. It went away so we though nothing of it but over the past couple of days it's been back and I traced it down to the control unit on the hot water tank. I jiggled the wire going into it and the lcd screen went blank. Usually this screen has some numbers on it so I'm guessing the unit died. I just went down again and jiggled it some more and the noise came back but the LCD screen is still off. So, my questions are.

- Is there any way to force it to heat without this so I can get hot water?
- Could this be related to the repair a couple of weeks ago?
- How can I test if the unit is bad or maybe it's a loose wire? The noise makes me feel like the unit is broken.
- I tried to Google the numbers of it but I came up empty, where could I find a replacement unit for this

RyanD is offline   Reply With Quote
Old 12-23-2009, 10:14 PM   #2
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,735
Default

Water Heater Control unit makes noise then shut off...


Check to see if any of teh wires are loose.

Can't make hot water if that control is bad.

beenthere is offline   Reply With Quote
Old 12-23-2009, 10:46 PM   #3
Member
 
Join Date: Jul 2008
Location: NW of D.C.
Posts: 5,990
Default

Water Heater Control unit makes noise then shut off...


Quote:
Originally Posted by RyanD View Post
I jiggled the wire going into it and the lcd screen went blank. Usually this screen has some numbers on it so I'm guessing the unit died.
The trick is to find a single connection that makes the screen go and come back when you wiggle the wire going into it. Tapping with a pencil may also cause the problem to show itself.
If the wires are bundled you may have to temporarily unbundle them.

It may be related to the repair, or a coincidence. If the relay is buzzing it also points toward a loose connection. If you have a schematic it might help if you post it.

Last edited by Yoyizit; 12-23-2009 at 10:50 PM.
Yoyizit is offline   Reply With Quote
Reply

Tags
hot water amtrol tank


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water connections for new water heater diggerdave Plumbing 16 03-16-2009 10:36 AM
Gas Hot Water Heater - Help? MaximumAsh Plumbing 22 03-13-2009 10:57 AM
Electric water heater noise mc73 Plumbing 1 05-22-2008 09:57 AM
water heater noise boman47k Plumbing 5 11-28-2007 06:31 AM
Periodic release from (I think) the T&P valve on the water heater alexz Plumbing 3 08-15-2006 10:31 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.