DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Utica MGB75HID boiler wont start (http://www.diychatroom.com/f17/utica-mgb75hid-boiler-wont-start-87882/)

need to know 11-27-2010 04:47 PM

Utica MGB75HID boiler wont start
 
This boiler was installed in 2004, but I have only owned the house since 2008. Both winters 2008 and 2009 the boiler worked fine. It has a Honeywell Ignitor S86ooM, a on/off toggle switch and a dedicated breaker. The breaker is on and in the past two years, when I flip the toggle to fire up the boiler for the winter, it starts right up. This year, nothing. I have checked the breaker, and all of the other electrical and electronic connections, everything seems fine, except it makes no noise. It doesnt even appear to be trying to start up. I have also checked the thermostat red and white wires, both are connected.

beenthere 11-27-2010 07:55 PM

Does the guage show that the boiler has any water pressure in it. Does sit have a low water cut off.

need to know 11-27-2010 08:08 PM

The gauge isnt reading anything. Not sure about the Low water cut off. How would I find out? (No owners manual)

Thanks.

beenthere 11-27-2010 08:20 PM

Low for a control marked as such. may have the initials LWCO.

need to know 11-27-2010 08:43 PM

Not seeing anything LWCO.

beenthere 11-27-2010 08:55 PM

May not have one. But if you do. they can prevent your boiler from working.


All times are GMT -5. The time now is 11:10 PM.