Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-03-2010, 08:38 PM   #1
Newbie
 
Join Date: Jan 2010
Posts: 5
Share |
Angry

Utica MGB125HID not working.


Here it goes...Utica model MGB125HID Serial# CT04940 not working all the time. What I found out so far is this water on floor and what I believe is the honeywell gas valve (VR8204/8304) when opened manually alows the heater to work just fine but it does not work by itself. Currently -5 degress outside! Please help. Thanks J.


Last edited by AF4501; 01-07-2010 at 11:41 AM. Reason: Got it fixed. Look in last post, maybe help you!
AF4501 is offline   Reply With Quote
Old 01-03-2010, 08:54 PM   #2
Member
 
Join Date: Oct 2009
Location: Nebraska
Posts: 2,362
Default

Utica MGB125HID not working.


Is the water on the floor from a plugged condensate line or something else leaked? Circuit board get wet?

Marty S. is offline   Reply With Quote
Old 01-04-2010, 12:03 AM   #3
Newbie
 
Join Date: Jan 2010
Posts: 5
Default

Utica MGB125HID not working.


The water is just from the "overflow" valve and dripping only. pressure is good and temp is not to high eigther, when its running. board is a ok except for the valve that has honeywell stamped/embosed on it.
AF4501 is offline   Reply With Quote
Old 01-06-2010, 06:02 PM   #4
Newbie
 
Join Date: Jan 2010
Posts: 5
Default

Utica MGB125HID not working.


Anyone have any idea about this problem?
AF4501 is offline   Reply With Quote
Old 01-06-2010, 06:16 PM   #5
Member
 
Join Date: Dec 2008
Location: West Michigan
Posts: 440
Default

Utica MGB125HID not working.


The only gas you should be able to produce manually from that valve is pilot gas. If you are getting main burner gas manually you need to replace that valve before it causes a hazardous situation. The leaking relief valve should not be leaking. What is the pressure in the system? If the system is low on water and you have a low water cut out you will have burner issues. Might be best to call a pro.
SKIP4661 is offline   Reply With Quote
Old 01-06-2010, 09:10 PM   #6
Newbie
 
Join Date: Jan 2010
Posts: 5
Default

Utica MGB125HID not working.


I mistook this valve. Its not a valve but it seems to be like a reset switch i.e. electrical. When kept open heater runs fine but the heater will not run properly on its own. I'm afaid this switch is a safety switch. The cause for the heater to turn off stay off is unknown. But that being said when kept open water pressure is good and water temp is good no safety problems there. Might be an electrical issue. I hope this will help J.
AF4501 is offline   Reply With Quote
Old 01-07-2010, 11:40 AM   #7
Newbie
 
Join Date: Jan 2010
Posts: 5
Default

Utica MGB125HID not working.


Its all fixed now thanks for all the help! It turned out to be one of the zone valves was not working. Pro fixed it no problem. I hope this may help others, look to the zone valves first. Check them to see if any of the wires look burned. Again thanks everyone J.

AF4501 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
central ac not working like it used to diyer1 HVAC 12 07-15-2009 02:30 AM
side by side light swithes not working katkell2645 Electrical 2 10-17-2008 07:22 PM
Inside Fan not working BenH HVAC 20 07-08-2008 06:10 AM
Working with granite... SDeeter19464 Remodeling 5 06-14-2008 05:51 AM
GE fridge evaporator fan change and still not working Trish Appliances 2 03-30-2008 01:47 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.