Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-11-2009, 12:02 PM   #1
Newbie
 
Join Date: Dec 2008
Posts: 6
Rewards Points: 10
Default

Troubleshooting Robertshaw T-19


Greetings!
I've encountered a very strange problem with a VAV terminal that uses a T-19 stat, and a reversing relay for the damper motor/reheat valve.
The reversing relay was constantly bleeding air, so I replaced it yesterday.
Today I got a call that the thermostat is now constantly bleeding air when it goes into a call for cooling! I've tried different stats, but they all do the same thing.
Any comments or suggestions would be sincerely appreciated!
Steve

STEVE IN OC is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thermostat Wiring & Troubleshooting guide Hippie HVAC 7 10-25-2009 10:02 AM
Troubleshooting Robertshaw Ignition milkshake36 HVAC 4 09-28-2009 10:49 AM
newbie HVAC troubleshooting elm66 HVAC 1 06-22-2009 08:38 PM
Help with voltage troubleshooting epicurux Electrical 5 07-02-2007 07:51 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.