DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Trane XL80 blows fuse (http://www.diychatroom.com/f17/trane-xl80-blows-fuse-163024/)

BluMagoo 11-12-2012 12:17 AM

Trane XL80 blows fuse
 
I have a Trane XL80 furnace. It was intermitantly working for a week or so. The burner would come on then go out after a few seconds and so on. Then it just started working again. Now the furnace has stopped all together. I found that the 5 amp fuse on the board was blown. I replaced it did a couple tests. I turned the power on with the heat turned off on the thermostat. The red light on the board started blinking steady again. I turned the fan on and the fan came on fine. Then I turned the heat on and the fuse blew. I don't see any damaged wires or anything. What could be wrong?

ben's plumbing 11-12-2012 07:43 AM

Quote:

Originally Posted by BluMagoo (Post 1050071)
I have a Trane XL80 furnace. It was intermitantly working for a week or so. The burner would come on then go out after a few seconds and so on. Then it just started working again. Now the furnace has stopped all together. I found that the 5 amp fuse on the board was blown. I replaced it did a couple tests. I turned the power on with the heat turned off on the thermostat. The red light on the board started blinking steady again. I turned the fan on and the fan came on fine. Then I turned the heat on and the fuse blew. I don't see any damaged wires or anything. What could be wrong?

unwire stat wires off control board...jumper r to w see if fuse blows....if it don't bad stat...if it does need to continue checking....ben sr


All times are GMT -5. The time now is 01:21 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved