DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Trane xl-90 2 stage furnace problems (http://www.diychatroom.com/f17/trane-xl-90-2-stage-furnace-problems-18205/)

ikon07 03-08-2008 06:28 PM

Trane xl-90 2 stage furnace problems
 
Hi everyone.
I bought Trane xl-90 2 stage furnace 4 years a go.
but since then i have to pay for repair every year.
the problem was the control board was bad. i they already replaced the control board 4 times. every time they came i had to pay for diagnostic and labor. now it is down again. but this time is difference. the fan was running at slow stage. the red light had 3 flashes. i look in " intergated furnace control flash codes chart. it say that draft pressur error. i try to turn it off and on few times but it didn't help. please help me.
thank you very much

HVACguy 03-10-2008 11:46 AM

I Would Check For A Few Things...

A: Make Sure The Pressure Switch Tubes Are Clear (Spiders Love To Make Their Homes There)

B: Check For Any Obstruction In Your Flue Pipe (Tis The Season)

C: If You Have A Man-o-meter Check The Pressure Out of The Inducer Motor - To Make Sure It Is Not A Faulty Inducer

D: With The 90% Furnace - Make Sure The Inducer Motor Is Not Swimming In Water - It Requires Proper Drainage To Drain The Condensation.

C: If It's Been An Issue Since The Furnace Was Installed - What Size PVC Did They Use To Exhaust? Most Common Mistake In High Efficiency Furnace Installations Is Improper Exhaust Size. How Many BTU's Is Your Furnace Rated At?

ikon07 03-11-2008 12:40 PM

Hi HVACguy.
thank you very much for your time.
i called service already. the technician came. he cleaned the enducer motor and all small black pip.turn the furnace on it still didn't work. He think that enducer motor problem and he is going to order new part for it. while i was writting this my technician called back and let me know that my furnace was installed in 2004 but the furnace was made in 2001 so it is not under 5 year warranty. the motor cost over $500 plus labor. i really don't know what to do now.

HVACguy 03-11-2008 02:59 PM

That Doesn't Sound Right...

With The Units I Carry - They Parts Warranty Starts The Date Of The Installation, Not The Production Date.

I Would Contact Trane/American Standard - And Talk To The Customer Care Department and Explain The Situation. The Part Should Be Under The 5 Year Warranty...

http://www.trane.com/Residential/Cus.../Feedback.aspx

And If I Am Not Mistaken - The OEM Motor In The 90% 2 Stage Units Where Deemed To be A Bad Design. I Have Replaced Multiple Trane Variable Speed Inducer Motors.. And Yes, They Are Quite Expensive. I Would Contact Customer Care and Ask.

It's Worth A Shot!

ikon07 03-13-2008 01:28 PM

Trane xl-90
 
Hi HVACguy.
Thanks again for your time.
Here is the update. My new service technician called Trane supplier again and this time he found out that my furnace was build in 03 insteed 01 so the warranty still ok. Yesterday technician came back to fix my furnace. He replaced control board, inducer motor, 2 switches. all part are difference than what i have (KIT15019). it is working now and hopefully my nightmare is over. i followed the link you gave me to contact customer care. He took my info and say someone will call me back within 2 days if not call them back. this time i had to pay $83 for diagnostic and $279 for the labor.:(

HVACguy 03-14-2008 09:14 AM

Well, Glad It All Worked Out!

Labor Is Cheep When You Have A Good Company Servicing Your Equipment!


All times are GMT -5. The time now is 02:43 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved