Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-28-2011, 08:44 AM   #1
Newbie
 
Join Date: Aug 2009
Posts: 5
Share |
Default

Trane XE80 - No heat, No suprise


Hey guys

I have an ancient Trane XE80 furnace in the basement. It has been slowly falling apart for years and i have been piecing it back together. This year, this week to be specific, it has decided to only intermittently give us heat.

There is no error code on the board, just a normal call for heat. The HSI works fine, the gas clicks on and will ignite at times. Sometimes it is a inconsistent ignition sequence that keeps repeating until only the blower is working. Other times it follows the expected route of heating until it has reached the correct temp.

The control board is new as of last year. The air filter is new as of a week ago. There doesnt seem to be any blockages. The flame sensor was just cleaned. Any help would be GREATLY appreciated.

Thank You

P.S. If you can please post pictures because i have no manual that points out specific parts.

ggutier49 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trane Aux heat modification tj1mcd HVAC 2 12-05-2009 07:24 PM
Trane Heat Pump Not Blowing Cold JbIcon HVAC 3 09-01-2009 10:15 AM
trane x19i heat pump MrSnapRon HVAC 8 08-29-2009 01:17 PM
Trane XE80 not(?) hot enough rossl56 HVAC 5 11-28-2008 02:34 AM
Are Trane heat pumps and Am Std exactly the same? jgtaylorjr HVAC 1 06-01-2008 09:35 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.