Trane XE 80 Problem - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 11-18-2008, 02:55 PM   #1
DIYer
 
Espy's Avatar
 
Join Date: Nov 2008
Location: Raleigh, NC
Posts: 6
Rewards Points: 10
Send a message via AIM to Espy Send a message via Yahoo to Espy Send a message via Skype™ to Espy
Question

Trane XE 80 Problem


White-Rodgers 50A65-475 circuit board. LED is continuously off indicating no power. However, the fan runs continuously.

My suspicion is that lightning may have fried the circuit board. Everything *was* working before. It is possible that the A/C is working but I'm not 100% certain; the temperature does drop though slowly, perhaps. However, the heat never starts and again, either way, the fan runs continuously.

The LED is supposed to flash once when power is first turned on as it does its self-check but now nothing happens.

I don't want to replace the circuit board (50A65-475) until I can absolutely confirm that is the problem. I am a little confused that the fan runs continuously when power is on to the system. Is that on a different circuit with a default of "on"? The thermostat fan setting is "auto", not "on".

Is there an obvious test I can try (with a multi-meter, perhaps) to verify the circuit board needs to be replaced? Is there something else that might be the issue here?

If I do have to replace the circuit board, will any 50A65 do? It seems the 475 model has been superseded. Finally, where's the best place to get a replacement? I found a 50A65-843 on an HVAC website for about $190. Should I be able to do better than that?

Many thanks in advance for all help.

Advertisement

Espy is offline   Reply With Quote
Old 11-18-2008, 06:20 PM   #2
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,630
Rewards Points: 2,000
Default

Trane XE 80 Problem


if you have a good 24V at the board on power into it the board is shot.....that fan cconstantly might be a relay within that works on having power to open the fan control (relay) in auto.

Advertisement

biggles is offline   Reply With Quote
Old 11-18-2008, 06:31 PM   #3
Member
 
Join Date: Nov 2008
Location: palm coast fl
Posts: 588
Rewards Points: 500
Default

Trane XE 80 Problem


look at the wireing diagram and look for the limit circuit many times if the unit is in the middle of a heating cycle and power goes out as in a storm it causes the furnace to overheat and trip a limit especially if its a downflow unit most limits reset automaticly however some have to be reset if youre savy enough with a meter you can read the entire limit circuit at once thru the wires (diagram)
kennzz05 is offline   Reply With Quote
Reply

Tags
50a65 , led , trane , xe 80


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trane XL1200 - Outdoor Unit Problem snifred81 HVAC 5 08-07-2012 02:53 PM
Stymied by window leakage problem. Matth3w General DIY Discussions 5 06-11-2008 07:26 PM
Trane XE 80 Problem ShotgunW HVAC 14 12-30-2007 10:00 PM
Trane 80xl, 3 flashes error light - draft pressure problem, help? Xsta HVAC 1 10-14-2007 09:20 PM
Post-Tension Slab Problem Advice/Help Mike McBride Building & Construction 2 01-09-2007 02:51 PM




Top of Page | View New Posts