DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Trane XB80 burner question (http://www.diychatroom.com/f17/trane-xb80-burner-question-161486/)

jjh 10-29-2012 06:45 AM

Trane XB80 burner question
 
My heater hasn't come on after turning it on for the first time this year. I get a constantly flashing LED - normal call for heat - and the ignitor comes on, but the burner won't light. The gas valve is on, and despite the burners not coming on, the unit runs then constantly and the LED blinks fast with no interruptions.

I'm down to the gas being the problem. The gas to the unit is working. Could it be clogged burners? If so - how to clean them? A faulty gas valve? Pressure switch?

Any help is appreciated to keep from calling the service guys out...but it's getting chilly.

jjh 10-29-2012 07:07 AM

Update
 
I don't hear a click right before the ignitor lights, making me think that either the gas valve isn't getting triggered to open, or is getting a signal sent but is not opening. Don't hear gas flowing and don't smell gas in the unit itself.

How can I tell which of these is going on? What is the fix? Something best left to the pros?

JJboy 10-29-2012 11:04 AM

use a voltimeter to check if you get 24v at the gas valve

Sent from my iPhone using DIY Forum

hvactech126 10-29-2012 06:46 PM

gas valve gets power AFTER the ignitor is glowing


All times are GMT -5. The time now is 01:33 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved