Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-28-2010, 08:56 AM   #1
Member
 
Join Date: Nov 2007
Posts: 64
Rewards Points: 75
Default

Thermostat blank - no heat/ac - fan works


So my thermostat screen went blank and the ac or heat do not turn on/work. However, if I switch the thermostat to "FAN" mode the fan still does turn on but still with a blank LCD screen - so hopefully this is a thermostat and not a hvac unit issue.

The thermostat is a newer Honeywell, the system is a heat pump. So far:
I checked the breaker box
checked wires in and out of the thermostat, air handler, and outdoor unit
I don't see any evidence of blown fuses or loose wires but I guess I need to pull off the side of the air handler and take a closer look. And probably do so electrical testing. But figured I'd post this in hopes someone with a similar problem could point me in the right direction - thanks!

snosurfa7 is offline   Reply With Quote
Old 10-28-2010, 09:32 AM   #2
Member
 
Join Date: Nov 2007
Posts: 64
Rewards Points: 75
Default

Thermostat blank - no heat/ac - fan works


Well I called Honeywell they said check the voltage between the R and G wires - if its between 24 and 30 the thermostat is bad - if not, contact a contractor (or more questions to come on this forum).

Did have a quick question anyway for now: I have a simple voltage tester but not a voltage meter - would something like this suffice?

http://www.northerntool.com/shop/too...ct_12496_12496

thanks

snosurfa7 is offline   Reply With Quote
Old 10-28-2010, 09:44 AM   #3
fabrk8r
 
fabrk8r's Avatar
 
Join Date: Feb 2010
Location: Iowa
Posts: 849
Rewards Points: 500
Default

Thermostat blank - no heat/ac - fan works


That tester will work fine.
__________________
"The physician can bury his mistakes, but the architect can only advise his clients to plant vines." -- Frank Lloyd Wright

Last edited by fabrk8r; 10-28-2010 at 09:48 AM.
fabrk8r is offline   Reply With Quote
Old 10-28-2010, 04:07 PM   #4
Member
 
Join Date: Oct 2010
Posts: 275
Rewards Points: 250
Default

Thermostat blank - no heat/ac - fan works


Some T-stat needs battery to run..
clocert is offline   Reply With Quote
Old 10-29-2010, 11:42 AM   #5
Member
 
Join Date: Nov 2007
Posts: 64
Rewards Points: 75
Default

Thermostat blank - no heat/ac - fan works


No battery on this one...fortunately, I have 26 volts from "R" to any other wire so it looks like hopefully just the thermostat is shot. Which is fine, those are pretty cheap and I can now upgrade to a programmable one...

Thanks for the help!
snosurfa7 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trane XR90 blower works but no heat/ac ttrotta3 HVAC 1 11-08-2010 09:35 AM
Carrier Edge Thermostat Installation Issue ptalar HVAC 1 07-13-2010 05:40 PM
Honeywell Prestige HD thermostat wiring 1H/1C + Humidification System TekGamer HVAC 0 07-09-2010 11:58 PM
New Thermostat Acting Strangely stormchaser88 HVAC 2 06-18-2010 04:25 PM
Problem with Lennox Pulse Furnace Wiring to Thermostat scalvin Electrical 4 12-30-2009 07:48 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.