DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Tempstar issue with cooling cycle (http://www.diychatroom.com/f17/tempstar-issue-cooling-cycle-23326/)

Teddy1731 07-07-2008 07:45 PM

Tempstar issue with cooling cycle
 
Hey guys I have an odd question. Brand new tempstar furnace when the AC kicks on the blower seems to prepurge then an audible click is heard blower goes off and click coninues intermittently almost like the igniter or a relay then the blower comes on and cooling begins. This doesn't seem right to me and is quite frankly very annoying. I feel as though it is trying to begin a heating cycle could this be my thermostat or does this 90 plus furnace just always go through prepurge before the blower starts. Am I hurting my new furnace? Thanks for the help

statman 07-08-2008 08:24 AM

Doesnt sound right. Try shutting off your thermostat and using only the fan switch on/off. Does the same clicking occur then? If so, the problem is more than likely in your furnace. It should NOT go into prepurge before the fan kicks on in cooling mode. Maybe a loose connection at your board or possibly a bad relay on the board.

Teddy1731 07-08-2008 10:15 AM

There is no clicking in fan only mode. Sequence of operation is as follows. Fan is on all the time to circulate air, thermostat to cooling mode, fan stops one clickis heard and fan comes on at higher speed. then 20 sec s apart two clicks are heard with no change in fan speed or operation I guess is this normal.


All times are GMT -5. The time now is 12:28 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved