DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Strange problem....just FYI (http://www.diychatroom.com/f17/strange-problem-just-fyi-162074/)

JJboy 11-03-2012 08:13 PM

Strange problem....just FYI
 
I got a strange problem today on a Goodman GME80905CX. Blower motor and Induce draft motor are constantly running even with Tstat off or the wires disconnected. Time to replace the controller board.

yuri 11-03-2012 08:23 PM

Some Goodmans have the limit control in series with the gas valve not the transformer so you may have an open limit or rollout switch. Is that a mid or high efficiency unit? Won't always give or read the proper code when they are in series. Constant running fan is usually an open high limit. Bad grounding of the board killed a lot of their boards a while back.

JJboy 11-03-2012 09:32 PM

Hey Yuri, It's nice see you again. Yes, there is a limit control in series with gas valve. I checked the rollout switch and high limit. I'm not getting any voltage on R at controller board.

Houston204 11-04-2012 01:30 AM

http://www.goodmanmfg.com/Portals/0/...s/IO-GMH95.pdf

Looks like a shorted flame sensor will run both fans. Any trouble codes displayed?

http://i151.photobucket.com/albums/s...diagnostic.jpg

JJboy 11-04-2012 01:52 AM

6 flashes...I checked for shorts, etc.....I stopped the troubleshooting when I measured 0V on R. Next week I'll have a controller board on hand, also I'll check the flame sensor first.

yuri 11-04-2012 08:34 AM

Did you check the output from the transformer? Getting 24 volts there? Hate to state the obvious. Sounds like the board is bad as with a dead transformer usually nothing happens at all.

JJboy 11-04-2012 11:28 AM

Yes, I did check it. I didn't check the aux limit switch that one it is connected in series with the gas valve.

With the wires from tstat disconnected, when I close the door switch, I hear the relay click to power the blower motor and also the induce started running at the same time.

JJboy 11-07-2012 06:44 PM

Ok, today I replaced the control board. It fixed the problem.


All times are GMT -5. The time now is 10:58 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved