DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Ruud UGAC-O6KC (http://www.diychatroom.com/f17/ruud-ugac-o6kc-122908/)

emeraldfrogy 11-09-2011 03:42 PM

Ruud UGAC-O6KC
 
Need help...

Ruud Furnace
Model UGAC-O6KC (0orO)
Serial TN3D104 F2083 6467

electric ignition, when I watch it, it clicks, the ignitor does not light the pilot. I manually light the pilot, after about 30 seconds, the pilot clicks and goes out. about 15 seconds later it click again but does not light, I light it again, the burners do not light,. I have cleaned the rod that is supposed to tell the sensor there is a flame? I just moved in here it was inspected, and ok'd I can't figure it out. PGE is coming on the 15th I'm freezing. Thanks for any help.

harleyrider 11-09-2011 08:15 PM

obviously the ignition module is bad........

how 11-09-2011 08:32 PM

I think harley has it right but just in case its a partially obstructed pilot.....
when you manually light the pilot, does the pilot flame fully envelope the flame sensor?
Do you see the spark when it clicks and is that spark in the path of the pilot flame?

emeraldfrogy 11-09-2011 08:44 PM

No Flame at all, it clicks, but nothing. When I light it, it is a large flame coming from 2 different small pipes one points to the burners, one to the heat rod. It should light, but apparently nothing is telling it to.

how 11-09-2011 09:17 PM

It seems like both the electronic ignition and the flame sensing system is at fault so the ignition module is the part to change.


All times are GMT -5. The time now is 09:33 PM.