Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-05-2007, 10:28 AM   #1
Newbie
 
Join Date: Nov 2007
Posts: 8
Share |
Default

Ruud 90 plus ignition problem


I could use some help here. My Ruud 90 plus started acting up last season. It's been in service since 1994. It takes a long time to ignite when it's stone cold. I'm getting occasional blow back when it does light. However, it never does NOT ignite. I was out in the yard the other day near the vents and the gas odor was really strong prior to ignition. I checked the HSI and I can barely see it glow when the furnace starts. I remember looking at it a few years ago in the sight glass and it glowed red hot. Is it possible that the HSI unit is getting tired or should I suspect the logic board? I'm expecting a new HSI unit today. I'd also like to take out the burner and clean it but I don't know if that will damage the gasget or even if it's recommended. I have the installation manual and everything happens in proper sequence, it just takes a long time. How much of this unit could/should I take apart and clean? Any help is appreciated.

HSI came yesterday - of course it was incorrect. Checked the HSI voltage with my multimeter. The heater tried to ignite 4 times before it started. There was voltage to the HSI each time so I have to assume the HSI is not doing it's job. I'm still moving ahead in getting a new HSI since it's the original.

Last edited by MrFixit55; 11-06-2007 at 07:03 AM. Reason: Additional info.
MrFixit55 is offline   Reply With Quote
Old 11-06-2007, 10:56 AM   #2
Thoroughbred Mopar Man
 
Join Date: Oct 2006
Location: South/East Kansas
Posts: 637
Default

Ruud 90 plus ignition problem


Hi MrFixit55

You would probably be money ahead to pull and clean the burners. As far as the low glow on the ignitor, there is a good chance the ignitor itself has a fracture in it and is not glowing completely. If you are getting a blow back that could be an indication of a sooted heat exchanger. This is why I say to pull and clean the burners. This will allow you to see into the heat exchanger. If you see a bunch of black stuff in front of the burners or inside the heat exchanger opening. Call in the pro's for this one, the heat exchanger will have to be pulled out of the furnace and tore apart to be properly cleaned. Hope this helps you understand, let us know if you need further assistance.

Good luck
Rusty
__________________
Character is doing the right thing even when no one is looking. Intelligence is understanding and practicing the meaning of character.
#CARRIERMAN is offline   Reply With Quote
Old 11-06-2007, 11:57 AM   #3
Newbie
 
Join Date: Nov 2007
Posts: 8
Default

Ruud 90 plus ignition problem


Funny thing is that I called a so-called pro last month. I called the installing dealer and they sent a tech who said "gee, I've only seen a handfull of these. It's kinda old. You should consider replacing it. I do installs on the side". I almost bodily threw him out the door. He said he had no clue what might be wrong. That's when I decided to learn everything I could about the heater and make the repair myself. This gas furnace is a bit different from the Bryant I had in my last house. I took the burner apart pre-season every year and cleaned it. This Ruud is a different animal. I'm going to take the burner unit out and clean it as soon as I can get a gasket. Haven't been able to find one yet that doesn't come with the untire burner kit. I'll keep looking. Thanks for the insight on the burner and HSI.
MrFixit55 is offline   Reply With Quote
Old 11-07-2007, 11:01 AM   #4
Newbie
 
Join Date: Nov 2007
Posts: 8
Default

Ruud 90 plus ignition problem


Well, the HSI crapped out last night. CARRIERMAN, you were right. I had no continuity on the HSI with my multimeter. I removed and inspected the HSI and, just like you said, there must have been a fracture that finally let go. New one to arrive tomorrow. BRRR!!! It's getting cold here in VF.
MrFixit55 is offline   Reply With Quote
Old 11-20-2007, 10:35 AM   #5
Newbie
 
Join Date: Nov 2007
Posts: 8
Default

Ruud 90 plus ignition problem


Forgot to update this. It WAS the ignitor. I replaced it and the burner lights on the first try and there is no more blowback. I see a nice healthy glow in the window from the HSI when it lights. Here is a warning!! The logic board is expecting a specified resistance (ohms) reading from the HSI once the ignitor switches roles from ignitor to flame sensor. The replacement was not a Rheem/Ruud part. It is made by ISI. The burner kept shutting off once the HSI unit turned off and that really had me scratching my head. After cycling the furnace about a dozen times and several lock-outs, it eventually stayed on. The resistance on the HSI has changed from the time it was new to when it started working but I don't have those specs at the time I wrote this. With this heater I'd recommend a factory HSI. I also had to modify the heads of 2 screws with a dremel so I cound properly seat the gasget.
MrFixit55 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
This may help someone with carrier ignition problems AweMan HVAC 15 02-09-2009 01:20 PM
Post-Tension Slab Problem Advice/Help Mike McBride Building & Construction 2 01-09-2007 01:51 PM
ruud furnace problem troubled1 HVAC 4 10-18-2006 04:14 PM
carrier 58SX ignition problem typhoon55 HVAC 5 06-08-2005 09:18 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.