Rheem Criterion II Won't Ignite - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 10-26-2012, 11:52 PM   #1
Newbie
 
Join Date: Oct 2012
Posts: 7
Rewards Points: 10
Default

Rheem Criterion II won't ignite


I have a Rheem Criterion II that will not ignite the gas. Blower comes on, cycles through, and releases gas but the igniter never glows. I put a meter on the line for the HSI and the voltage climbs to 9VAC but never exceeds that amount. Pulled the HSI and gave it 120VAC from the wall. It glowed red hot. Checked the voltage at the pressure switch and it climbs to 24VAC for a short while and then drops to zero. Disconnecting the connector to the pressure switch and checking the voltage at the connector it remains at a steady 24VAC. I can manually light the furnace and it will run normally. Does anyone have any ideas here? How do I know if its the board? Is there another test for the pressure switch? Any help would be greatly appreciated.

Advertisement

roundstones is offline   Reply With Quote
Old 10-27-2012, 02:17 AM   #2
how
Member
 
Join Date: Feb 2011
Location: Vancouver BC
Posts: 1,552
Rewards Points: 620
Default

Rheem Criterion II won't ignite


I think that unit is supposed to have a diagnostic led.

(1) BLINK FOLLOWED BY A 2 SEC. PAUSE 1 HOUR LOCKOUT
(2) BLINKS FOLLOWED BY A 2 SEC. PAUSE PRESSURE SWITCH IS OPEN
(3) BLINKS FOLLOWED BY A 2 SEC. PAUSE LIMIT SWITCH IS OPEN
(4) BLINKS FOLLOWED BY A 2 SEC. PAUSE PRESSURE SWITCH CLOSED
A FIFTH CODE IS ADDED ON DELUXE MODELS THAT HAVE TWINNING CAPABILITIES
(5) BLINKS FOLLOWED BY A 2 SEC. PAUSE - FAULT.

Advertisement

how is offline   Reply With Quote
The Following User Says Thank You to how For This Useful Post:
roundstones (10-27-2012)
Old 10-27-2012, 11:31 AM   #3
Newbie
 
Join Date: Oct 2012
Posts: 7
Rewards Points: 10
Default

Rheem Criterion II won't ignite


Thank you. I'll check for the LEDs.
roundstones is offline   Reply With Quote
Old 10-27-2012, 04:26 PM   #4
Member
 
Houston204's Avatar
 
Join Date: Oct 2009
Location: Texas
Posts: 594
Rewards Points: 514
Default

Rheem Criterion II won't ignite


If you are getting gas and the hsi works with your test, you need a new board.
Houston204 is offline   Reply With Quote
The Following User Says Thank You to Houston204 For This Useful Post:
roundstones (10-31-2012)
Old 10-28-2012, 10:43 PM   #5
Newbie
 
Join Date: Oct 2012
Posts: 7
Rewards Points: 10
Default

Rheem Criterion II won't ignite


The board is the only possibility at this point?
roundstones is offline   Reply With Quote
Old 10-29-2012, 06:49 PM   #6
Newbie
 
Join Date: Oct 2012
Posts: 7
Rewards Points: 10
Default

Rheem Criterion II won't ignite


Okay so trying to run the furnace I get a 1 hour lockout error code. Checking the resistance at the gas solenoid, I get 280 ohms resistance. I don't have a schematic and can't track down the relay for the HSI. Traced the wires from the HSI through a couple of connections and back to the board at a 6 pin socket. There's a little black Siemens component directly above the 6 pin socket. It looks like there might be a circuit trace from the 6 pin to the component. The other side of the 6 pin appears to go to neutral. Is this Siemens component the relay? Any ideas what I might be looking for? Thanks.
roundstones is offline   Reply With Quote
Old 10-30-2012, 01:12 PM   #7
Newbie
 
Join Date: Oct 2012
Posts: 7
Rewards Points: 10
Default

Rheem Criterion II won't ignite


Is there a source for the HSI relay and is it worth it to just change out the relay?
roundstones is offline   Reply With Quote
Old 10-30-2012, 04:49 PM   #8
how
Member
 
Join Date: Feb 2011
Location: Vancouver BC
Posts: 1,552
Rewards Points: 620
Default

Rheem Criterion II won't ignite


Have you confirmed what the board is trying to feed the HSI.
Not all HSI run on 120V.
how is offline   Reply With Quote
Old 10-31-2012, 01:17 AM   #9
Newbie
 
Join Date: Oct 2012
Posts: 7
Rewards Points: 10
Default

Rheem Criterion II won't ignite


I have not gotten more than 9VAC at the HSI from the board. It (the HSI) tests out at about 200ohms of resistance. That would make the current .045 amps or 45 mA. Does this seems like it could light up an HSI? I don't know much about these but I thought this one was supposed to get 120VAC. What do you think? I was able to get it to glow when I applied 120VAC during a bench test with the HSI pulled from the furnace and given a dedicated line from the wall.
roundstones is offline   Reply With Quote
Old 10-31-2012, 01:36 AM   #10
how
Member
 
Join Date: Feb 2011
Location: Vancouver BC
Posts: 1,552
Rewards Points: 620
Default

Rheem Criterion II won't ignite


Sorry but folks measure things here in so many different ways.

Unplug the HSI, and measure what the board is supplying in VAC with a call for heat?

Last edited by how; 10-31-2012 at 01:44 AM.
how is offline   Reply With Quote
Old 10-31-2012, 02:22 AM   #11
Newbie
 
Join Date: Oct 2012
Posts: 7
Rewards Points: 10
Default

Rheem Criterion II won't ignite


I did. That's when I got the 9VAC measurement from the board. I disconnected the HSI and plugged the multimeter directly into the connector coming from the board. The resistance measurement on the HSI was done when it was isolated and not on the circuit.
roundstones is offline   Reply With Quote
Old 10-31-2012, 02:42 AM   #12
how
Member
 
Join Date: Feb 2011
Location: Vancouver BC
Posts: 1,552
Rewards Points: 620
Default

Rheem Criterion II won't ignite


Thanks for the clarification.
Insufficient voltage to the HSI with codes saying its not a safety limit or PS fault, all point to a board problem.
With board problems, always check that all your ground lines are good but beyond that I'd be replacing the board.

Advertisement

how is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rheem Criterion 2 efficiency mwpaulson HVAC 23 11-03-2012 03:23 PM
Problem with Rheem Criterion Furnace sweetsue777 HVAC 3 03-10-2012 12:13 PM
Rheem Criterion II Igniter Larry Haage HVAC 9 01-15-2012 12:02 AM
Rheem Criterion II Cycles Constantly ewatts2003 HVAC 0 01-11-2011 11:03 PM
Need some help with Rheem Criterion II macaluso1 HVAC 4 01-05-2009 10:07 PM




Top of Page | View New Posts