Problem With Trane XE78 - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 12-25-2008, 03:12 PM   #1
Newbie
 
Join Date: Dec 2008
Posts: 2
Rewards Points: 10
Default

Problem with Trane XE78


Having problems with my approximately 15-year-old Trane XE78. A couple of days ago it started to smell like electrical overheating type smell coming out of the vents. We have two units in the house one upstairs and one all the way downstairs itís the unit downstairs that is producing the smell. It also seems to be louder when it kicks on. I switched it off and saw a blinking light on a circuit board. It appears to be blinking continuously so I canít tell how many blinks. Please keep in mind I have no experience in this type of repair so pictures would be helpful if you know of a website that uses pictures, or any ideas if I have to call a repairman so I can give the impression that I have even a small clue
Thanks

Advertisement

Bruno2005 is offline   Reply With Quote
Old 12-25-2008, 03:27 PM   #2
Electrical Contractor
 
kbsparky's Avatar
 
Join Date: Sep 2008
Location: Delmarva
Posts: 3,368
Rewards Points: 2,000
Default

Problem with Trane XE78


Burning smell coming from the environmental air is a sign of a bad connection in your aux strip heaters, or bad element, etc.

You might want to have a competent service person check this one out. Too much at risk (fire, smoke, etc) to ignore ....

Advertisement

kbsparky is offline   Reply With Quote
Old 12-25-2008, 04:04 PM   #3
Newbie
 
Join Date: Dec 2008
Posts: 2
Rewards Points: 10
Default

Problem with Trane XE78


Thank you think we will be calling one tomorrow.............looked at it again since I posted and it almost sounds like the blower motor maybe burning out. Thanks again for your expertise
Bruno2005 is offline   Reply With Quote
Old 12-25-2008, 05:37 PM   #4
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 26,532
Rewards Points: 4,702
Default

Problem with Trane XE78


Quote:
Originally Posted by kbsparky View Post
Burning smell coming from the environmental air is a sign of a bad connection in your aux strip heaters, or bad element, etc.
I think you'll find a Trane XE78 is a gas furnace.

No strip heaters.
beenthere is online now   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trane XL1200 - Outdoor Unit Problem snifred81 HVAC 5 08-07-2012 02:53 PM
Problem with Trane gas furnace quovadis HVAC 17 12-22-2008 02:12 PM
Trane XE 80 Problem Espy HVAC 2 11-18-2008 06:31 PM
Trane XE 80 Problem ShotgunW HVAC 14 12-30-2007 10:00 PM
Trane 80xl, 3 flashes error light - draft pressure problem, help? Xsta HVAC 1 10-14-2007 09:20 PM




Top of Page | View New Posts