Problem With My HEIL SP80 Gas Furnace - HVAC - DIY Chatroom Home Improvement Forum

Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC


Thread Tools Display Modes
Old 10-23-2011, 06:47 AM   #1
Join Date: Oct 2011
Posts: 1
Rewards Points: 10

Problem with my HEIL SP80 Gas Furnace

I have a HEIL SP80 gas furnace. When I turn it on the ignitor comes on and the flame is there, but it doesn't ignite the burner and the blower doesn't come on and start blowing warm air. If I disconnect a relay wire it resets and will come on, sometimes it takes a couple of times doing it. After the set temp is reached, and it kicks off, it doesn't come back on. It will keep cycling through but the blower will not come back on by itself again. Can anybody please help?


rayray1700 is offline   Reply With Quote
Old 10-23-2011, 10:15 AM   #2
I'm Your Huckleberry
Join Date: Mar 2011
Posts: 5,884
Rewards Points: 2,270

Sounds like a bad ignitor.


Doc Holliday is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Inside/Around American Standard Furnace michrob HVAC 8 12-08-2011 03:51 PM
Heil Gas Furnace Ultimate II - High Limit Switch Triggering Problem hiei5 HVAC 11 07-24-2011 12:23 PM
Lennox Elite Series Furnace Problem steges HVAC 7 11-06-2010 02:49 PM
Hvac heil furnace problem jimbflo HVAC 0 11-12-2009 09:23 PM
Strange Problem with My Furnace chenjijc HVAC 14 11-04-2009 09:05 PM

Top of Page | View New Posts


Search Engine Friendly URLs by vBSEO 3.6.1