DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Payne 376C Stopped working (http://www.diychatroom.com/f17/payne-376c-stopped-working-104605/)

dhigginx 05-15-2011 07:34 PM

Payne 376C Stopped working
 
I have a Payne 376c Furnace that seems to have just stopped working. The inducer motor turns on and eventually the blower motor turns on but the HSI never heats up so of course the burners never light. Is there anything that this specifically indicates??

BTW, the furnace uses a 310305-201 controller so it has no diagnostic dsplays. Also, shorting together the two self test pins didn't seem to do anything.

Marty S. 05-15-2011 08:26 PM

Voltage to the HSI ?

dhigginx 05-15-2011 08:45 PM

I just checked about 2.5Vac

Marty S. 05-15-2011 08:52 PM

Bad control board then.

dhigginx 05-15-2011 09:33 PM

I so $229.87 hoped that wasn't the problem!!!

dhigginx 05-31-2011 07:19 PM

I pulled the controller board out in anticipation of replacing it and I thought that just for grins I would check the output of the 24V transformer. To my surprise it read 6.6v. I have a feeling that this may be the only problem, should I replace it first?


EDIT: I actually had a meter battery problem. When I replaced the battery I found that the transformer was putting out at least 24v (28.? actually) I then double checked the voltage to the HSI and came up with 6.7V.

Does this still sound like the Control Board is bad?


All times are GMT -5. The time now is 06:27 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved