Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-12-2011, 07:51 PM   #1
Newbie
 
Join Date: Jan 2011
Posts: 3
Share |
Default

Older (late 80's) Carrier burners not staying lit


I have a older (late 80's) Carrier model # 58sx080-bc-1 that the inducer motor went out of 3 days ago.
I put in a new A.O. Smith 580 and cage,reasembled and when I turned the furnace back on it went through all the steps.
Inducer motor
pilot light
then the burners TRIED to ignite but did not and wont no more than a second.
I checked all the wire connections making sure I did not knock any off.
It ran fine before motor went out.
Here is a link to a vid I took of what the flame does. It will eventually light the pilot again and repeat never staying lit longer than this. Thanks
http://www.youtube.com/watch?v=nwfCz3GKVNU
FSHNROD is offline   Reply With Quote
Old 01-12-2011, 07:59 PM   #2
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Older (late 80's) Carrier burners not staying lit


new vent motor may not be keeping the ps closed. Check ps hose for cracks or leaks
kenmac is offline   Reply With Quote
Old 01-12-2011, 08:22 PM   #3
Newbie
 
Join Date: Jan 2011
Posts: 3
Default

Older (late 80's) Carrier burners not staying lit


Quote:
Originally Posted by kenmac View Post
new vent motor may not be keeping the ps closed. Check ps hose for cracks or leaks
Well that led me to this but has me confused.
Right now the furnace is working , but this is what I had to do.
The ps had a hose off but when I would put that hose on the pilot light would go out ?
I took off the plate ( with the site glass to burners) then hooked up hose to ps and then flipped the power switch to watch .................
the pilot lit and burners came on and stayed on ?
So I tried again with the plate on, flipped switch.....nothing.
I took the plate back off and repeated until the burners lit THEN put plate back on . As of now it is still on but it hasnt had a chance to kick off to see if it comes back on by itself.
Could it be the pressure switch bad causeing this ?
FSHNROD is offline   Reply With Quote
Old 01-12-2011, 08:32 PM   #4
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Older (late 80's) Carrier burners not staying lit


Sounds like your not getting combustion air in the chamber for it to burn. Is this furnace vented with plastic vent pipe ?
kenmac is offline   Reply With Quote
Old 01-12-2011, 08:38 PM   #5
Newbie
 
Join Date: Jan 2011
Posts: 3
Default

Older (late 80's) Carrier burners not staying lit


yes it is.
I tried to kick it back on again and it will not do it with that plate on.
Take the plate off let it light and put it back on its fine till it shuts off again.
You can take the hose off from the inducer to the switch and the pilot will light but the burners wont stay lit that way

Last edited by FSHNROD; 01-12-2011 at 08:47 PM.
FSHNROD is offline   Reply With Quote
Old 01-13-2011, 07:04 AM   #6
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Older (late 80's) Carrier burners not staying lit


2 pipe sysyem or single ? check intake air for obstructions
kenmac is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carrier 58SXA main burner problem... bfordmn HVAC 5 11-12-2011 09:14 AM
Older Carrier Pilot Burner Problem cliffkot HVAC 23 04-29-2011 05:58 PM
How to check secondary heat exchanger on Carrier SXC? Vaandjay HVAC 3 12-19-2010 11:27 AM
Compare Carrier Model 25HNA936A003 versus Model 25HPA636 gchapman General DIY Discussions 0 11-02-2010 12:52 PM
Carrier Unit not cycling properly kentk1 HVAC 20 01-12-2009 03:06 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.