Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-14-2010, 06:51 PM   #1
Newbie
 
Join Date: Oct 2010
Posts: 11
Share |
Default

Older Carrier Pilot Burner Problem


I have an older, model 58SE Carrier furnace that stopped working. The pilot lights but the MGV will not open. The furnace has electric ignition and uses an Intermade pilot burner, and 24vac (actually measures 28vac.) If I short the connections, wht/yellow on the pilot burner lead, the MGV opens and
everything runs great. Further tests revealed that the MGV will open with as little as 16vac at 250 ma. (0.250 amp).

I got an new pilot burner from PSINtermade. Installed it. Same problem. Decided to check the new pilot burner by disconnecting the cable from the circuit and operating the gas valve by jumpering. The pilot burner NC contacts (Yel/Grn wires) read 0.7 ohm closed. Within 10 seconds
of lighting the pilot, the NC contacts opened. If connected they would have dropped the pick valve and igniter off line. This is normal.

I then checked the NO (cold) contacts (Yel/Wht). They were still open. In the circuit, had they been connected, the MGV would not have opened. I waited a minute. Same thing. 2 minutes 3 minutes,... 10 minutes. Nothing. Still open.

The pilot flame looks good, envelops the whole head of the pilot burner with enough flame squirting out the right hand side to enter the main burner chamber.

PSintermade claims they checked the burner before it was sent. What is wrong?

While I'm not an HVAC guy, I am an electrical engineer with a lot of experience. This is a simple bimetallic switch, or so I'm led to believe.

Any ideas?

Cliff


Last edited by cliffkot; 10-15-2010 at 09:16 AM.
cliffkot is offline   Reply With Quote
Old 10-14-2010, 07:20 PM   #2
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 9,048
Default

Older Carrier Pilot Burner Problem


Why would they test the burner(sounds suspicous) and how did they do it w/o a furnace. The ones I get are in a sealed bag and never have a problem. I prefer the OEM Carrier one rather than the generics. Make sure you get a nat.gas one and not a propane one as it has a smaller orifice/unless you are using Propane.

__________________
"Cut it twice and it is still too short".
yuri is online now   Reply With Quote
Old 10-14-2010, 07:37 PM   #3
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Older Carrier Pilot Burner Problem


If you have the old 3 or 2 wire bryant / carrier bi metal pilot. The flame isn't hot enough to bent the metal or the metal is bent out of original shape & make the circuit. Like Yuri said. make sure it's for the correct gas



Like this

Last edited by kenmac; 10-14-2010 at 07:41 PM.
kenmac is offline   Reply With Quote
Old 10-14-2010, 07:41 PM   #4
Newbie
 
Join Date: Oct 2010
Posts: 11
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by yuri View Post
Why would they test the burner(sounds suspicous) and how did they do it w/o a furnace. The ones I get are in a sealed bag and never have a problem. I prefer the OEM Carrier one rather than the generics. Make sure you get a nat.gas one and not a propane one as it has a smaller orifice/unless you are using Propane.

Well I don't think there is an OEM supplier for Carrier anymore except Psintermade. I think they put a lot of companies out of business, I can't find any other manufacturer.

What happened is that a couple of years ago my furnace started cycling every couple of seconds. I jumpered the pilot burner switch and it worked fine, so I got a new pilot burner. It fixed the problem. This year it quit again.

I contacted the manufacturer and they sent me a new one, I sent them the old. Put it the new one. It didn't work. They claim the old one is OK too. Well obviously something isn't right. Thats when I decided to do some critical testing of both the pilot burner and Main Gas Valve. I found that my valve works beautifully. Pulls in with a measly 16vac and .25 amp. On the other hand the new pilot burner never closes after it heats up. The NC contacts open quickly(10-15 secs), as they should after the pilot lights, but the Normally Open (NO) contacts never close.

The only unknown for me is the size of the pilot flame. It looks good, but who knows.
cliffkot is offline   Reply With Quote
Old 10-14-2010, 07:42 PM   #5
Newbie
 
Join Date: Oct 2010
Posts: 11
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by kenmac View Post
If you have the old 3 or 2 wire bryant / carrier bi metal pilot. The flame isn't hot enough to bent the metal or the metal is bent out of original shape & make the circuit. Like Yuri said. make sure it's for the correct gas



Like this
That's the part all right. i used the orifice that they sent me. how can you tell which is which?
cliffkot is offline   Reply With Quote
Old 10-14-2010, 07:46 PM   #6
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Older Carrier Pilot Burner Problem


You would have to take the orifice out . I put the orifice on top of a flashlight. If you haven't seen a propane orifice vs ng you might not be able to tell the difference. Propane is smaller hole. Like yuri said . unless they connected it . How would they know it worked
kenmac is offline   Reply With Quote
Old 10-14-2010, 08:17 PM   #7
Newbie
 
Join Date: Oct 2010
Posts: 11
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by kenmac View Post
You would have to take the orifice out . I put the orifice on top of a flashlight. If you haven't seen a propane orifice vs ng you might not be able to tell the difference. Propane is smaller hole. Like yuri said . unless they connected it . How would they know it worked
They told me they have a testing machine that duplicates a furnace.
cliffkot is offline   Reply With Quote
Old 10-14-2010, 08:20 PM   #8
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by cliffkot View Post
They told me they have a testing machine that duplicates a furnace.


It's not getting hot enough or there's something wrong with the wire connections in the assy
kenmac is offline   Reply With Quote
Old 10-14-2010, 08:46 PM   #9
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 9,048
Default

Older Carrier Pilot Burner Problem


IMO it would be very difficult to simulate a furnace as it has draft and a lower temp than some bench tester. Your pilot regulator may be sending too low a pressure to the unit. That is a gnarly old furnace with a heat exchanger that is ready to fail.I had one with a intermittent sticking gas valve that caused a huge bang/delayed ignition from not opening fast enough and the timing was off. Unsafe to use and scared the customer half to death with a gas smell. If it is the mid efficiency unit with the board behind the ventor fan those are a nightmare to troubleshoot and that board can damage the lower board. We sort of abandoned a poster a while back because very few guys know how to service that old unit and could not help him. You may be on your own. I would look into a new furnace or be prepared to spend lots of time and $$ trying to keep it running. After 25 yrs there is not a great demand for parts and the manufacturers start dwindling down the OEM parts supply and the generics are not nearly as good. All about supply and demand.
__________________
"Cut it twice and it is still too short".

Last edited by yuri; 10-14-2010 at 08:50 PM.
yuri is online now   Reply With Quote
Old 10-14-2010, 10:46 PM   #10
Newbie
 
Join Date: Oct 2010
Posts: 11
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by kenmac View Post
It's not getting hot enough or there's something wrong with the wire connections in the assy
I was thinking about not getting hot enough. Do you know whether the pilot flame is supposed to be 2 stage. In other words is it hotter before the burner kicks in ?

Will the pilot flame reduce when the pick coil is de-energized?

Does anybody know?

cliff
cliffkot is offline   Reply With Quote
Old 10-15-2010, 05:39 AM   #11
Member
 
Join Date: Dec 2008
Posts: 50
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by cliffkot View Post
I have an older Carrier furnace that stopped working. The pilot lights but the MGV will not open. The furnace has electric ignition and uses an Intermade pilot burner, and 24vac (actually measures 28vac.) If I short the connections, wht/yellow on the pilot burner lead, the MGV opens and
everything runs great. Further tests revealed that the MGV will open with as little as 16vac at 250 ma. (0.250 amp).

I got an new pilot burner from PSINtermade. Installed it. Same problem. Decided to check the new pilot burner by disconnecting the cable from the circuit and operating the gas valve by jumpering. The pilot burner NC contacts (Yel/Grn wires) read 0.7 ohm closed. Within 10 seconds
of lighting the pilot, the NC contacts opened. If connected they would have dropped the pick valve and igniter off line. This is normal.

I then checked the NO (cold) contacts (Yel/Wht). They were still open. In the circuit, had they been connected, the MGV would not have opened. I waited a minute. Same thing. 2 minutes 3 minutes,... 10 minutes. Nothing. Still open.

The pilot flame looks good, envelops the whole head of the pilot burner with enough flame squirting out the right hand side to enter the main burner chamber.

PSintermade claims they checked the burner before it was sent. What is wrong?

While I'm not an HVAC guy, I am an electrical engineer with a lot of experience. This is a simple bimetallic switch, or so I'm led to believe.

Any ideas?

Cliff
I have two 20 year Bryant units with the infamous 3 wire pilot sensor. One unit never gave me a problem. The other had a 3 wire pilot failure about 6 years ago. I replaced it with a new factory OEM unit which has never operated right. It takes several minutes to satisfy. Sometimes, when it is very cold and the unit has not been run for a while, the bimetallic switch never closes and the furnace locks out. I put up with this because I don't want to shell out $100 for a new pilot. I have done a fair amount of research on these 3 wire pilots and they are notoriously unreliable even when brand new.

If I read your post correctly, you have confirmed that the 3 wire pilot is not closing even when exposed to a strong pilot for several minutes. If this is true, you need to get a new one.
artbuc is offline   Reply With Quote
Old 10-15-2010, 07:00 AM   #12
HVAC / Plumbing
 
Join Date: Feb 2009
Posts: 1,801
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by cliffkot View Post
I was thinking about not getting hot enough. Do you know whether the pilot flame is supposed to be 2 stage. In other words is it hotter before the burner kicks in ?

Will the pilot flame reduce when the pick coil is de-energized?


cliff

No & it shouldn't. Most of these That I use to see in the field were set up for pilot to burn all the time
kenmac is offline   Reply With Quote
Old 10-15-2010, 09:20 AM   #13
Newbie
 
Join Date: Oct 2010
Posts: 11
Default

Older Carrier Pilot Burner Problem


To test my idea of insufficient pilot flame, I fired up the pilot and then added some supplementary heat to the pilot burner module itself with a small flame from a propane torch. The pilot burner contacts still failed to close.

Not what do you guys think.

Cliff
cliffkot is offline   Reply With Quote
Old 10-15-2010, 09:25 AM   #14
Newbie
 
Join Date: Oct 2010
Posts: 11
Default

Older Carrier Pilot Burner Problem


Quote:
Originally Posted by artbuc View Post
I have two 20 year Bryant units with the infamous 3 wire pilot sensor. One unit never gave me a problem. The other had a 3 wire pilot failure about 6 years ago. I replaced it with a new factory OEM unit which has never operated right. It takes several minutes to satisfy. Sometimes, when it is very cold and the unit has not been run for a while, the bimetallic switch never closes and the furnace locks out. I put up with this because I don't want to shell out $100 for a new pilot. I have done a fair amount of research on these 3 wire pilots and they are notoriously unreliable even when brand new.

If I read your post correctly, you have confirmed that the 3 wire pilot is not closing even when exposed to a strong pilot for several minutes. If this is true, you need to get a new one.
Where did you get the info on their unreliability? I need some ammo because I'm going to have to argue with a manufacturer.

thanks
cliffkot is offline   Reply With Quote
Old 10-15-2010, 11:35 AM   #15
Member
 
Join Date: Dec 2008
Posts: 50
Default

Older Carrier Pilot Burner Problem


Sorry, I can't give you anything definitive. I just remember asking about my problem on several DIY/HVAC forums and got many remarks about poor design/reliability of these pilot assemblies. I doubt if anecdotal experience will help you too much.

artbuc is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heil Furnace Burner Problem timothyr HVAC 79 02-12-2014 07:01 PM
Pilot lite on Carrier Furnace goes out nmac HVAC 8 10-08-2012 06:32 AM
Ignitor Problem Carrier rjs123 HVAC 5 12-15-2010 05:23 PM
Original problem to beckett burner question.. jmhai HVAC 17 01-14-2010 04:25 PM
pilot light reignition on older williams model Unregistered HVAC 1 02-17-2004 09:26 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.