Oil Burner Question - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 10-14-2012, 02:33 PM   #1
Newbie
 
Join Date: Oct 2012
Posts: 1
Rewards Points: 10
Talking

oil burner question


hi
i have a warmflow 50/90 slimline kabinpak oil burner and when i run out of oil, obviously i refill,turn it on at the switch and it sounds like its working,but its not heating anything, there was a new pump put in last year and the pipe going from burner to the pump is cold, this has happened a few times, eventually after hours of turning it on and off it does start burning and heating,but it seems to be getting much worse.
does anyone have any advice.
tom

Advertisement

tomthumb is offline   Reply With Quote
Old 10-14-2012, 04:54 PM   #2
Member
 
Join Date: Jul 2012
Location: Toronto ON
Posts: 599
Rewards Points: 500
Default

oil burner question


when you let it run out of oil the pump loses ot's prime then the air in the pump has to be bled out..there is a bleeder screw on one of tyhe pump fittings ..approx 1/4 inch ..put container under to catch oil, loosen screw and run pump until clear stream of oil ...tighten screw and proceed to start up sequence. you will likely have to just run through start sequence several times to get the air bled out.

Get make and model of pump and go online to see if you can get manufacturer's mechanical drawings/pics of pump in order to locate bleeder screw..some are hard to find

Advertisement


Last edited by techpappy; 10-14-2012 at 04:59 PM.
techpappy is offline   Reply With Quote
Old 10-14-2012, 04:59 PM   #3
Member
 
Join Date: Oct 2011
Location: pa
Posts: 4,614
Rewards Points: 2,542
Default

oil burner question


Quote:
Originally Posted by tomthumb View Post
hi
i have a warmflow 50/90 slimline kabinpak oil burner and when i run out of oil, obviously i refill,turn it on at the switch and it sounds like its working,but its not heating anything, there was a new pump put in last year and the pipe going from burner to the pump is cold, this has happened a few times, eventually after hours of turning it on and off it does start burning and heating,but it seems to be getting much worse.
does anyone have any advice.
tom
just a thougth don't let it run out of oil before you refill...
ben's plumbing is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Venting over the range convection oven question johncle6023 HVAC 4 08-31-2012 09:30 PM
Question about gas burner design darsunt HVAC 4 12-14-2008 02:37 PM
Basement Renovation Question KUIPORNG Remodeling 234 08-26-2008 09:19 AM
hrv question indep HVAC 3 07-17-2008 11:39 PM
Wood Burner Installation Question? fisher501 HVAC 1 12-22-2005 10:29 PM




Top of Page | View New Posts