DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Is my control board really defective? (http://www.diychatroom.com/f17/my-control-board-really-defective-187993/)

mstankiewicz 10-03-2013 06:05 PM

Is my control board really defective?
 
Hello folks,
I recently had to replace the control board on my furnace. (N9MSB)
The board I purchased is identical to the original. (OEM 1184594)
I received it in a new, unopened condition. No physical defects to be seen.. So I swapped the board out and took it for a spin.. I ran it through a cooling cycle.. Worked great. As for the heating, not so much. It always locks out at the moment the gas valve should energize, with error light on, solid, meaning: gas valve stuck open, flame sense circuit failure, or software check error.

Gas valve operates normally if I give it 24 volts.
Flame sensor appears to be in good condition and only a year old.

I have put a voltmeter across the gas valve, it never receives 24 volts.
I have followed the service manual flow chart for this furnace and it recommends to replace the board. I am just looking for some guidance from the pro's here, before I try to find another board and spend more money.

Thank you for your help!!!

yuri 10-03-2013 06:54 PM

Is it a Heil furnace or what is the brand name. Post some pics of it with both doors off.

If the flame sensor is grounded ( porcelain may be cracked or the rod is touching ground) or the flame sensor wire is grounded/shorted then the board may lock out as it is sensing a "false flame". May need to replace that wire. It needs to be a heat resistant wire or get the OEM one, needs to be a silicone or the heat resistant wire they use in stoves.

mstankiewicz 10-03-2013 07:11 PM

4 Attachment(s)
Thank you for the response!
The brand is Comfortmaker. Attached are some photos of the furnace itself. I can provide more photos or details if needed.
How can I test if the flame sensor is short or grounded?

mstankiewicz 10-03-2013 07:18 PM

I forgot to add that if I energize the gas valve at the correct time during the startup cycle, (17 seconds after HSI begins) the control board light blinks as if going through a normal heating cycle. (It detects flame.)

hvac5646 10-03-2013 07:21 PM

Quote:

Originally Posted by yuri (Post 1249168)
Is it a Heil furnace or what is the brand name. Post some pics of it with both doors off.

If the flame sensor is grounded ( porcelain may be cracked or the rod is touching ground) or the flame sensor wire is grounded/shorted then the board may lock out as it is sensing a "false flame". May need to replace that wire. It needs to be a heat resistant wire or get the OEM one, needs to be a silicone or the heat resistant wire they use in stoves.

spark plug wire. works great heat resistant and cheap.

hvac5646 10-03-2013 07:36 PM

it's worth mentioning your furnace is under warranty. Why did you buy a part when the factory part warranty is still in effect?

yuri 10-03-2013 07:42 PM

Yeah, we don't tolerate trolls here.

mstankiewicz 10-03-2013 07:50 PM

The part was replaced due to moisture, so I did not think that would be covered.. ( I am a first time home owner, so go easy on me. :)

yuri 10-03-2013 08:02 PM

If it was not too wet looking then you might have got away with it but it depends on the dealer if he wants to take that chance or be a nice guy.

Technically the control should lockout but you should not be fooling around with energizing any gas valve and WE DO NOT condone that here for safety reasons.

Try a new wire and yeah a spark plug wire should do the trick.

It uses DC flame rectification ( Google that) and you may be hitting it at the right time /sequence but you may have also damaged the new board or it may now be compromised and UNSAFE. you cannot tell with electronics and you may have backfed voltage to it or damaged it. I would NOT feel safe with it now and especially with your family there too.

mstankiewicz 10-03-2013 08:03 PM

I appreciate you guys taking the time to give me advice. I just bought some heat resistant wire, wish me luck. Will post back shortly.

yuri 10-03-2013 08:06 PM

reread my post as I added to it.

hvac5646 10-03-2013 08:07 PM

too many tests to be made that require genuine experience on this one.

hvac5646 10-03-2013 08:12 PM

Quote:

Originally Posted by yuri (Post 1249203)
If it was not too wet looking then you might have got away with it but it depends on the dealer if he wants to take that chance or be a nice guy.

Technically the control should lockout but you should not be fooling around with energizing any gas valve and WE DO NOT condone that here for safety reasons.

Try a new wire and yeah a spark plug wire should do the trick.

It uses DC flame rectification ( Google that) and you may be hitting it at the right time /sequence but you may have also damaged the new board or it may now be compromised and UNSAFE. you cannot tell with electronics and you may have backfed voltage to it or damaged it. I would NOT feel safe with it now and especially with your family there too.

WHAT HE SAID^^^^^^


Is my control board really defective?

The part was replaced due to moisture, so I did not think that would be covered.. ( I am a first time home owner, so go easy on me. :)END QUOTE


That's counter intuitive. I must admit I have never heard of a person not trying to get coverage on a part on so new an appliance. Most would at least try.


WHAT MAKES YOU SO SURE MOISTURE IS THE PROBLEM ...sorry..caps locked up on me.

mstankiewicz 10-03-2013 08:33 PM

Quote:

Originally Posted by hvac5646
WHAT HE SAID^^^^^^

Is my control board really defective?

The part was replaced due to moisture, so I did not think that would be covered.. ( I am a first time home owner, so go easy on me. :)END QUOTE

That's counter intuitive. I must admit I have never heard of a person not trying to get coverage on a part on so new an appliance. Most would at least try.

WHAT MAKES YOU SO SURE MOISTURE IS THE PROBLEM ...sorry..caps locked up on me.

My furnace is in our cellar, (outside access.) We had a bad rain storm, and the door had not been securely shut. Everything inside cellar was wet and that is when the system quit working. The board was clearly damaged, (ill find the pic. )

@yuri what you're saying makes sense.

So I guess my next question is if anyone knows where I can purchase this board?

mc5w 10-27-2013 03:36 PM

Control Board May be partially Unplugging Itself
 
One time I had a problem with the locking tabs of the molex type wiring harness plug not automatically snapping in place. On a callback I had to push the plug back onto the board, puch the locking tabs closed, and then placed a miniature cable tie round the lcking tabs and then taped up the locking tabs with 1/2 inch electrical tape.

Stayed fixed.


All times are GMT -5. The time now is 02:51 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved