Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-08-2007, 06:19 PM   #1
Newbie
 
Join Date: Feb 2007
Posts: 1
Share |
Lightbulb

miller furnace problem


I have a miller mobile home gas furnace which sat idle for a year when I fired it after cleaning the blower keeps short cycling about 5min run flame stays on after 3 or 4 min the blower kicks on for 5 min and cyclr starts over ect. the furnace is a 1993 model #mgha-075abfc-01. can anyone help Thanks Rich.

cometcyclone is offline   Reply With Quote
Old 02-08-2007, 07:27 PM   #2
Newbie
 
Join Date: Feb 2007
Posts: 7
Default

miller furnace problem


sounds like flame sensor is dirty. Take it out and clean it off with a wire brush or emery. When that gets dirty it will short cycle.

TJ1960 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heil Furnace Burner Problem timothyr HVAC 79 02-12-2014 07:01 PM
New High Efficiency Furnace Problem Buster 567 HVAC 8 12-13-2010 08:36 PM
furnace problem captjack HVAC 8 11-23-2007 11:15 AM
another question for a miller furnace problem jb9270 HVAC 1 02-05-2007 02:04 PM
Miller Mobile Home Oil Furnace jjalba9 HVAC 1 01-22-2007 10:57 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.