Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-28-2011, 02:30 PM   #1
Newbie
 
Join Date: Oct 2011
Posts: 2
Share |
Default

Main Blower Runs All The Time


I just had a no start condition on a bryant High Efficiency Plus 90 Gas Furnace, diag to failed igniter, ordered on line installed starts fine now. However the main blower runs all the time. My wife says it has been doing this for past month. She turned it to off at the thermostate, keeps running, I was away on travel so I had her flip the power switch next to the furnace in the closet and shut the system down. The system responds to heat demand and will light off normally and cycle off when demand has been met. The main blower just wont cycle with it. I had cleaned the coils in the spring and I have excellent air flow. When the heat is off the unheated airflow makes the house feel drafty. The only codes were related to the igniter and that the power had been off. Can anyone share any history on this unit ? I am getting to know my way around it very well due to a really bad install. This sucker has died twice on New Years eve, at least it waited until after mid night last time. I am getting tired of sitting on my over turned home depot bucket in my boxers with a fluke meter in my lap at 2 am fixing it.

Needmotools is offline   Reply With Quote
Old 10-28-2011, 03:57 PM   #2
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,627
Default

Main Blower Runs All The Time


if you have a solid state board with in the furnace you have a timed delay fan ON for heating after the hamber heats up but as you said it should be the last thing to go off after the stat satisfies...if your stat is in AUTO?FAN and the fan still runs no system in OFF the relay on the board is probably welded closed.with the stat off on fan and system go down to the furnace and disconnect the G wire if the fan still runs the relay is closed that G pull should kill the 24Vs to open that board mounted relay"little black square".the older fans during heating depended on a metl KLIXON type disc to close from the burner temp rise...now they do a delay but the relays take the fan amps right thru the contacts and stick.note just in case info...the cooling runs HI fan and the heating runs a LO or Med LO as designed slower air take longer to heat up

biggles is offline   Reply With Quote
Old 10-28-2011, 05:58 PM   #3
Newbie
 
Join Date: Oct 2011
Posts: 2
Default

Main Blower Runs All The Time


Thanks for the direction. It sounds like what you described. Back in the spring the AC was icing up due to dirty coils. I was out of town and my wife had the fan on all the time to balance the upstairs temps. I mentioned the excellent airflow. Clue 1, it is blowing on high for sure. I will check the relay on the board when I get home tonight. I had replaced this board once before and I had to add a adapter harness to fit an upgrade running change in boards. Enough time has gone by that I do not recall what the upgrade was correcting for. Can I buy this relay or am I looking at a new board? If I need the board where can I order a board or relay. A local friend (HVAC tech) had a stroke and is out of the business. The local suppliers that I know of in the Washington Metro wont sell to a diy home owner. If I can solder micro bulbs into my trucks radio I can change relays, the million dollar question is where can I buy the parts after I confirm the failure ? Thank you very much for your advice.
Bill
Needmotools is offline   Reply With Quote
Old 10-28-2011, 06:18 PM   #4
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,627
Default

Main Blower Runs All The Time


if the fan is only in HI then your locked into it thru that relay.how it calls in the heating LO speed is something i don't know about....but constant HI fan is the problem here. check out this site for your board http://www.bestbuyheatingandaircondi...cuitboards.htm
biggles is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace fan runs all the time gsoukup HVAC 3 05-13-2011 05:32 PM
Wiring Size Calculations for New Service CorinthWest Electrical 7 12-07-2010 11:36 AM
Diy'er runs out of time & tools turning to the Pros Learn2Build Painting 5 09-20-2010 12:24 AM
Blower cycling and vibration whatshappening HVAC 1 02-09-2010 04:48 AM
Main blower is very slow on York Diamond 90 dnastrau HVAC 5 08-01-2009 01:11 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.