DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Luxaire heat pump wiring diagram (http://www.diychatroom.com/f17/luxaire-heat-pump-wiring-diagram-22505/)

StevieRay 06-19-2008 09:46 AM

Luxaire heat pump wiring diagram
 
I'm wondering if anyone here has a schematic for a Luxaire heat pump EBBA-F024SA outside unit, s/n ECFP012151. I've got a problem with the main contactor clicking when it should be running, and the wiring daigram inside the cover is GONE due to the weather.

Any other suggestions or troubleshooting hints? Sometimes (75% of the time) the thing runs fine, and then other times the contactor tries to pull in (and fan and compressor start) but immediately drops out. Sometimes it will "click" for a minute or two, then pull in and run fine. I think it may be the pilot relay on the defrost board, but I need a schematic to verify before I just throw money at it -- it could be just a connection or contact problem. I haven't tapped on any of the relays or contactor when it was trying to pull in. I don't have much experience with refridgeration, but many, many years of electrical / electronic service experience (BSEET in Industrial Automation). This thing can't be that hard to fix or troubleshoot -- I just need a diagram!

There's no longer a dealer / distributor in my area, and calling Luxaire -- well, let's just say they weren't very helpful since I was just Joe Consumer. It's like a secret society..........give me a break.

bmill 07-01-2008 08:45 PM

:thumbsup::censored:
Quote:

Originally Posted by StevieRay (Post 131793)
I'm wondering if anyone here has a schematic for a Luxaire heat pump EBBA-F024SA outside unit, s/n ECFP012151. I've got a problem with the main contactor clicking when it should be running, and the wiring daigram inside the cover is GONE due to the weather.

Any other suggestions or troubleshooting hints? Sometimes (75% of the time) the thing runs fine, and then other times the contactor tries to pull in (and fan and compressor start) but immediately drops out. Sometimes it will "click" for a minute or two, then pull in and run fine. I think it may be the pilot relay on the defrost board, but I need a schematic to verify before I just throw money at it -- it could be just a connection or contact problem. I haven't tapped on any of the relays or contactor when it was trying to pull in. I don't have much experience with refridgeration, but many, many years of electrical / electronic service experience (BSEET in Industrial Automation). This thing can't be that hard to fix or troubleshoot -- I just need a diagram!

There's no longer a dealer / distributor in my area, and calling Luxaire -- well, let's just say they weren't very helpful since I was just Joe Consumer. It's like a secret society..........give me a break.


bmill 07-01-2008 08:48 PM

same problem
 
daughter luxaire heat pump dose same pulling out hair runs when it feel like running

bmill 07-01-2008 08:50 PM

Quote:

Originally Posted by bmill (Post 135257)
daughter luxaire heat pump dose same pulling out hair runs when it feel like running

hold in contactors run good but dosen.t always dose it by itself any ideals

bob22 07-02-2008 07:20 AM

Have you replaced the contactor?

statman 07-02-2008 10:08 AM

Send your info to them and they should get you a diagram. Here is the contact link. ucg-upgconsumerrelations@jci.com


All times are GMT -5. The time now is 07:24 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved