Forums | Home Repair | Home Improvement | Painting | Interior Decorating | Remodeling | Landscaping


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-12-2013, 11:47 AM   #1
Pro re-work contractor
 
Join Date: Dec 2007
Location: NW Suburb Chicago
Posts: 19
Share |
Default

Luxaire error 7 flashes


Trouble again on my Luxaire g8t08012dna11a

It cycles 4 times by igniting and flames are present then again shuts down cycles to flame then after 4 or 5 trys it locks down with 7 flashes. But this error says no ignite??? If I play with this a few times I can get heat. But later on it fails again. I will take the cover off and that cuts power to the board and will do this again. I have fixed this unit twice before with your help and hoping I can get this going. I am very handy with electrical testers and such. Thanks guys for any help. Rick
analog414 is offline   Reply With Quote
Old 04-12-2013, 12:50 PM   #2
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 8,312
Default

Luxaire error 7 flashes


clean the flame sensor with steel wool or fine emory paper 400 grade or higher. should look like one of these. it cannot get a signal and thinks there is no flame. also clean the face of the burner it sits in front of or the fire wall in front of the sensor. it is sending a signal/current thru the flame to the burner or the wall and that conducts back to the board thru grounding. no flame no signal or it is so weak the board cannot read it.
Attached Images
  
__________________
"Cut it twice and it is still too short".
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by yuri; 04-12-2013 at 12:52 PM.
yuri is offline   Reply With Quote
The Following User Says Thank You to yuri For This Useful Post:
beenthere (04-12-2013)
Old 04-12-2013, 07:43 PM   #3
Pro re-work contractor
 
Join Date: Dec 2007
Location: NW Suburb Chicago
Posts: 19
Default

Luxaire error 7 flashes


Well yuri, problem solved!! THANK YOU
analog414 is offline   Reply With Quote
Old 04-13-2013, 07:42 AM   #4
Hvac Pro
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 8,312
Default

Luxaire error 7 flashes


Yur Welcome.
__________________
"Cut it twice and it is still too short".
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
yuri is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Confusing Luxaire GM9 Problem eccentric1 HVAC 11 09-20-2012 08:51 PM
Luxaire furnace problem pware724 HVAC 7 11-20-2011 08:47 PM
Luxaire Furnace Won't Fire ChuckAnderson HVAC 14 12-07-2010 09:19 PM
Trane TUY080 - 2 red flashes kuzya HVAC 2 05-03-2010 05:48 PM
Luxaire 4 red flashes error analog414 HVAC 2 11-11-2008 09:51 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.