Lennox Watchguard Problem - HVAC - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 12-23-2008, 12:40 AM   #1
Newbie
 
Join Date: Dec 2008
Posts: 1
Rewards Points: 10
Default

Lennox Watchguard Problem


Hello all and thanks for any help you can offer. I have a Lennox furnace that about a week ago started giving me problems. It will fire up fine, but after a few moments shuts off. It will do this several times then stop. It does a alternating slow flash between the two diag lights that indicates watchguard error. I'm at a loss of what to do. I climbed onto my roof today and looked into both of the ventilation pipes and both look clear as could be. The furnace itself seems to be igniting fine, so I don't know what else could really be the problem. My friend who lives 1 block away and has the same furnace started having a problem with his about 2 weeks ago, he paid a couple hundred dollars to a technician to come out and wipe off his sensor and now it works fine. He doesn't know where the sensor is located or what exactly the technician did aside from what he was told (he wasn't there when service was done). He told me that his wasn't even firing up though, and mine is so I don't know if that would even help me... Anyhow any advice would be appreciated... Also I checked what appeared to be the ground wire connecting to the frame and it doesn't look corroded or anything, looks fine.

Thanks,
Mike

Advertisement

mig83 is offline   Reply With Quote
Old 12-23-2008, 08:41 AM   #2
Member
 
Join Date: Sep 2008
Location: Upstate New York
Posts: 368
Rewards Points: 250
Default

Lennox Watchguard Problem


This post may help.

Advertisement

dac122 is offline   Reply With Quote
Old 12-23-2008, 09:58 AM   #3
Member
 
Join Date: Dec 2008
Location: West Michigan
Posts: 440
Rewards Points: 250
Default

Lennox Watchguard Problem


What's the model number? Could be al lot of things causing your problems.
SKIP4661 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lennox G12 Blower Motor Problem jimvh2 HVAC 7 06-28-2012 10:55 PM
Lennox furnace problem devgill08 HVAC 5 12-11-2008 08:38 PM
For all you Lennox owners ibwahooka HVAC 9 11-23-2008 05:06 AM
Stymied by window leakage problem. Matth3w General DIY Discussions 5 06-11-2008 07:26 PM
Lennox stuck in Watchguard Mode thate HVAC 12 11-17-2007 05:04 PM




Top of Page | View New Posts