DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Lennox HS19-261 won't blow cold air (http://www.diychatroom.com/f17/lennox-hs19-261-wont-blow-cold-air-72093/)

eaglemaniac642 05-25-2010 08:11 PM

Lennox HS19-261 won't blow cold air
 
Hi all,
Anyone out there every experience your A/C Unit preferably an Lennox HS19-261 that just won't put out cold air, it's cool not cold. I've already cleaned the outside unit, don't know how to tell if the compressor is working. Thank you for your help.

Marty S. 05-25-2010 08:20 PM

Feel the large insulated copper line going into the unit. Should be cold but not iced. Probably low on charge. If the compressor isn't running the air coming out of the registers will be room temp, not cool.

eaglemaniac642 06-04-2010 07:10 AM

Lennox HS19-261 won't blow cold air
 
Thank you, now I have a new question about this, I've been told this is a closed unit so if it's not blowing cold air there's a leak somewhere & since it uses R-12 I might want to just replace the whole system. Not looking to do that yet just trying to by some time till I can replace it.

beenthere 06-04-2010 02:29 PM

It doesn't use R12. Its an R22 system.

It may be low on refrigerant, it may not be.

A gas N go may get you through a year, a day, or 5 or more years.

Marty S. 06-04-2010 05:51 PM

Yep call a tech out and have him service and fill it up if needed. Might last through the summer and it might not.


All times are GMT -5. The time now is 07:24 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved