Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-04-2010, 08:56 PM   #1
Newbie
 
Join Date: Jan 2010
Posts: 7
Share |
Default

Lennox ghr26 furnace problems


Hey all

I have a lennox ghr26 furnace in my attic, it recently started acting up on me.
when i switch the furnace on it goes through its regular startup procedures, the inducer starts, burners ignite and blower starts, then the burner goes out, it relites several times and then the furnace shuts down before it reaches the required temperature. The furnace diagnosis is "watchguard, burners failed to ignite"

I have replaced the flame sensor and cleaned the spark ignitor but still nothing, Called in a technician and he could not figure out the problem. (some technician).

please help.

thank you

wayfis is offline   Reply With Quote
Old 01-04-2010, 10:58 PM   #2
Member
 
Join Date: Feb 2009
Posts: 41
Default

Lennox ghr26 furnace problems


Quote:
Originally Posted by wayfis View Post
my furnace starts up when the t-stat is switched on. Inducer starts up, gas ignites and blower starts, then burner goes out, and reignites agian. This happens several times and then the furnace shuts off.
I have replaced the flame sensor and that did not work.

any sugestions
thanks
bad ground to the board. open limit. possible crack in HX blowing air onto the flame sensor. How many seconds between burners igniting and extinguishing? How long till blower cycles on?

chard is offline   Reply With Quote
Old 01-04-2010, 11:16 PM   #3
Member
 
Join Date: Feb 2009
Posts: 41
Default

Lennox ghr26 furnace problems


Quote:
Originally Posted by wayfis View Post
Hey all

I have a lennox ghr26 furnace in my attic, it recently started acting up on me.
when i switch the furnace on it goes through its regular startup procedures, the inducer starts, burners ignite and blower starts, then the burner goes out, it relites several times and then the furnace shuts down before it reaches the required temperature. The furnace diagnosis is "watchguard, burners failed to ignite"

I have replaced the flame sensor and cleaned the spark ignitor but still nothing, Called in a technician and he could not figure out the problem. (some technician).

please help.

thank you
Bad ground to the igniton control board or bad board.
chard is offline   Reply With Quote
Old 01-05-2010, 06:16 AM   #4
Member
 
Join Date: Oct 2009
Location: Nebraska
Posts: 2,362
Default

Lennox ghr26 furnace problems


Could be dirt and rust on the face of the burners not completing the flame sense operation. The flame sensor is only part of the flame proving process. Try that first before buying a new board.
Marty S. is offline   Reply With Quote
Old 01-05-2010, 10:11 AM   #5
Newbie
 
Join Date: Jan 2010
Posts: 7
Default

Lennox ghr26 furnace problems


Quote:
Originally Posted by chard View Post
bad ground to the board. open limit. possible crack in HX blowing air onto the flame sensor. How many seconds between burners igniting and extinguishing? How long till blower cycles on?

How many seconds between burners igniting and extinguishing?
Its different every time, sometimes for a minute then a couple seconds

How long till blower cycles on?
about a minute
wayfis is offline   Reply With Quote
Old 01-05-2010, 10:15 AM   #6
Newbie
 
Join Date: Jan 2010
Posts: 7
Default

Lennox ghr26 furnace problems


Quote:
Originally Posted by Marty S. View Post
Could be dirt and rust on the face of the burners not completing the flame sense operation. The flame sensor is only part of the flame proving process. Try that first before buying a new board.
Burners are pretty clean, How do i test if i have a bad ground to the board
wayfis is offline   Reply With Quote
Old 01-05-2010, 11:50 AM   #7
Member
 
Join Date: Dec 2008
Location: West Michigan
Posts: 440
Default

Lennox ghr26 furnace problems


,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, ,,,,,,

Last edited by SKIP4661; 01-05-2010 at 12:11 PM.
SKIP4661 is offline   Reply With Quote
Old 01-05-2010, 11:51 AM   #8
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,787
Default

Lennox ghr26 furnace problems


Check vent pipe.
beenthere is online now   Reply With Quote
Old 01-05-2010, 05:51 PM   #9
Member
 
Join Date: Oct 2009
Location: Nebraska
Posts: 2,362
Default

Lennox ghr26 furnace problems


To check the flame proving have the heat on with flames working , your meter set on microamps and in series between the sensor and sensor wire. Reading has to be over 1 microamp for that board to keep the gas on.

Marty S. is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lennox Furnace burner won't stay on stevea7777 HVAC 47 03-14-2014 08:00 AM
lennox elite furnace leaking water outboardhuy HVAC 10 09-24-2011 10:43 AM
New Cased Coil - Install to Furnace - PICTURES!! hartkem HVAC 39 11-18-2008 01:45 AM
furnace and or electrical problems tuasoi General DIY Discussions 4 11-29-2007 12:50 PM
Intermittent gas furnace problems dcoz HVAC 1 01-16-2006 09:22 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.