Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-27-2011, 12:59 PM   #1
Newbie
 
Join Date: Oct 2011
Posts: 3
Share |
Default

LENNOX C23-41-1 Furnace IGNITOR IS NOT ENERGIZED


When I turn the heat on the combustion air blower runs, but ignitor won't turn red. The 2 LEDs on Controller borad are normal (Both SIMULTANEOUS FAST FLASH). After about 2 minutes, the fun stops and the LED2 becomes slow flash and LED1 off. According to the manual, it means Pressure Switch fails. I have 2 zone systems so there is another Lennox C23-51-1 (4 ton) there next to the C23-41-1 (3 ton). I switched controller, ignitor and pressure switch. It still has the same problem. I found that on the working C23-51-1, the 2 wires connected to the Pressure Switch both have about 25 vac to ground, but on the non-working furnace, the front wire has only about 1 vac. Any idea what the problem could be?

Thanks a lot.


Last edited by xuzhang; 10-27-2011 at 01:34 PM.
xuzhang is offline   Reply With Quote
Old 10-27-2011, 02:51 PM   #2
Newbie
 
Join Date: Oct 2011
Posts: 3
Default

LENNOX C23-41-1 Furnace IGNITOR IS NOT ENERGIZED


Quote:
Originally Posted by xuzhang View Post
When I turn the heat on the combustion air blower runs, but ignitor won't turn red. The 2 LEDs on Controller borad are normal (Both SIMULTANEOUS FAST FLASH). After about 2 minutes, the fun stops and the LED2 becomes slow flash and LED1 off. According to the manual, it means Pressure Switch fails. I have 2 zone systems so there is another Lennox C23-51-1 (4 ton) there next to the C23-41-1 (3 ton). I switched controller, ignitor and pressure switch. It still has the same problem. I found that on the working C23-51-1, the 2 wires connected to the Pressure Switch both have about 25 vac to ground, but on the non-working furnace, the front wire has only about 1 vac. Any idea what the problem could be?

Thanks a lot.


It is fixed. It was the Pressure Switch hose that connect to the fan, the small hole on the connector was blocked. Thanks.

xuzhang is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible Lennox Furnace ignitor problem Paulg1 HVAC 4 11-26-2010 04:38 PM
Lennox Elite Series Furnace Problem steges HVAC 7 11-06-2010 02:49 PM
Lennox Furnace Model #: 90UGFA3-75-6 GauravJ HVAC 3 10-30-2010 08:24 PM
Lennox Furnace Model #: 90UGFA3-75-6 GauravJ Electrical 0 10-29-2010 06:52 PM
Lennox ghr26 furnace problems wayfis HVAC 8 01-05-2010 05:51 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.