Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-29-2011, 08:47 PM   #1
Newbie
 
Join Date: Jan 2011
Posts: 5
Rewards Points: 10
Default

Kenmore 596 bottom freezer cold top warm


Kenmore frig with bottom freezer Model 596.67277790.

Yesterday the frig compartment got warm. The lower freezer compartment was 5 degrees and cold air blows into freezer when frig is running.

I took the panel off the back (inside the freezer) and there was no ice build-up at all. Drain hole was clear.

The defrost thermostat check out - has continuity when cold, no continuity when warm.

Vacuumed all the dust from the coils beneath the frig.

Took the cover off the controller at the upper back of frig compartment and the vent door with spring attached is wide open. Yet when cold air is blowing into the freezer below no air at all is coming out of the upper vent. I checked the lower end of that air duct, in the freezer, and there is no obstruction there.

With the unit unplugged I left the freezer door open for a few hours while I vacuumed all the dust from the coil underneath the frig. The freezer was then warm when I plugged the frig in and turned it on. I blows frigid air into freezer below and no air at all comes out up above.

I can't figure why cold air is not coming up and into the frig when the condenser is working and the fan in the freezer is blowing cold air.

Any suggestions will be appreciated.

klimshelf is offline   Reply With Quote
Old 03-30-2011, 06:45 AM   #2
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 25,994
Rewards Points: 3,658
Default

Kenmore 596 bottom freezer cold top warm


Check return vents behind crispers for blockage.

beenthere is online now   Reply With Quote
Old 03-30-2011, 09:32 AM   #3
Newbie
 
Join Date: Jan 2011
Posts: 5
Rewards Points: 10
Default

Kenmore 596 bottom freezer cold top warm


Quote:
Originally Posted by beenthere View Post
Check return vents behind crispers for blockage.
There is only one return vent, below the left crisper drawer, and it is clear.

I just tested the defrost timer and there is no continuity between ground terminal and any of the other three terminals, whether timer is on or off. That looks to be the likely suspect.

6 hours later. Parts guy checked defrost timer and it was bad. Replaced it. Frig is still short cycling - runs for 5 minutes and shuts off over and over - never long enough to cool the frig cabinet.

Two techs said it is either the compressor (read as New Frig) or the compressor relay.

The next day: replace compressor relay ($38). Frig running normally. Problem solved.

Last edited by klimshelf; 03-31-2011 at 09:58 PM.
klimshelf is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenmore fridge not cooling but freezer is working perfectly. l.shemon Appliances 14 08-26-2013 07:00 PM
Sequence of operation hot water heater pomelo Plumbing 5 01-25-2010 12:29 PM
question about cold air return locations ponch37300 HVAC 4 01-11-2010 09:56 AM
Freezer odors - coming from blower/fan Richo Appliances 3 05-27-2009 06:26 PM
Kenmore fridge not cooling, freezer ok bobvanhalder Appliances 20 10-23-2008 12:36 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.