DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   HVAC (http://www.diychatroom.com/f17/)
-   -   Keeprite inducer moter has water in it, low pressure switch fault (http://www.diychatroom.com/f17/keeprite-inducer-moter-has-water-low-pressure-switch-fault-124288/)

rbfox 11-22-2011 09:16 AM

Keeprite inducer moter has water in it, low pressure switch fault
 
I have a new 90mvx model that I installed. It ran fine until one day the blower motor would come on, igniter light up, gas for 10 secs then it would shut off. I would then see the three flashes on the led telling me pressure switch. I jumped out the switch and it worked!
For a while anyhow.
It seems there is a LOT of water in the fan and I can hear the motor working hard to get up to speed.
All the drain hose are connected but there is nothing to drain the fan cage.
What the heck did I do wrong?

HVACDave 11-22-2011 10:33 AM

There should be a conection between the inducer box and the condensate trap in the unit. Be sure that your drain hose is not plugged up outside the furnace and that it is not double trapped on its way to the drain. You could remove the drain hoses between the inducer housing and the trap and see if the water will come out there, if it does you need to find the problem downstream. If not then you need to clear the obstruction in the inducer housing.

rbfox 11-22-2011 11:55 PM

Figured it out. I was not level and the water was not draining.
All good now!!
Thanks for the help!!


All times are GMT -5. The time now is 02:58 AM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved