Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > HVAC

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-26-2012, 06:54 AM   #1
Newbie
 
Join Date: Aug 2012
Location: ny
Posts: 3
Share |
Default

kanhai


i have a evap coil 15 ton is chilled water system my supply is 35 and my return is 65 why do i get a high head should i punch the lines to see if it dirty ur is my mixing valve is the problem


Last edited by kanhai; 08-26-2012 at 08:25 PM.
kanhai is offline   Reply With Quote
Old 08-26-2012, 08:10 AM   #2
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,626
Default

kanhai


35/65 is the air temp going thru the coil? hi head might be a dirty condenser is that air cooled or water cooled....grab that Liquid Line if either is fouled the LL will be hot that is causing that high head..what freon and unit ....brand and style chiller is it.that 35F is pretty cold and near freezing why is it so cold entering the coil...40-45 is typical on commercial chillers

biggles is offline   Reply With Quote
Old 08-26-2012, 11:31 AM   #3
An old Tradesmen
 
Join Date: Oct 2008
Location: PA
Posts: 24,788
Default

kanhai


Low water flow through that coil, or else you have 8,000 CFM going through it instead of 6,000 CFM. What kind of flow control do you have on it.
beenthere is online now   Reply With Quote
Old 08-26-2012, 08:22 PM   #4
Newbie
 
Join Date: Aug 2012
Location: ny
Posts: 3
Default

kanhai


Quote:
Originally Posted by biggles View Post
35/65 is the air temp going thru the coil? hi head might be a dirty condenser is that air cooled or water cooled....grab that Liquid Line if either is fouled the LL will be hot that is causing that high head..what freon and unit ....brand and style chiller is it.that 35F is pretty cold and near freezing why is it so cold entering the coil...40-45 is typical on commercial chillers
should i punch the lines to see if it dirtyi have a mixing valve it open all the way
kanhai is offline   Reply With Quote
Old 08-26-2012, 11:58 PM   #5
Member
 
biggles's Avatar
 
Join Date: Jan 2008
Location: Long Island
Posts: 3,626
Default

kanhai


so the condenser is water cooled from the city water with the reg? or a tower if the LL is hot tubes might be slimed up..simple tube brush them will solve the hi head.i'm going with no work has been done on unit charging guages on and off...thinking air might of been sent into freon lines....what freon are you running?
biggles is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.